Bug 1857821 - Deployment Config overview shows 'e is undefined' exception when new pod is starting up
Summary: Deployment Config overview shows 'e is undefined' exception when new pod is s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.5.z
Assignee: ralpert
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1861116 (view as bug list)
Depends On: 1853705
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-16 15:50 UTC by ralpert
Modified: 2020-08-10 13:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: This was caused by a lack of handling for a bad pods parameter in getFailedPods. Consequence: Runtime error. Fix: Added optional chaining to parameter. Result: Bug is fixed.
Clone Of:
Environment:
Last Closed: 2020-08-10 13:50:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 6021 None closed Bug 1857821: Fix for pod ring exception 2020-08-21 13:43:24 UTC
Red Hat Product Errata RHBA-2020:3188 None None None 2020-08-10 13:50:39 UTC

Description ralpert 2020-07-16 15:50:35 UTC
This bug was initially created as a copy of Bug #1853705

I am copying this bug because: 
We want to backport the fix to 4.5.z.


Description of problem:
Page for Deployment Config overview showed me 'e is undefined' exception, when I tried to access it, when a new pod was starting up. After some time, when the pod is started and running, Deployment Config is again available.
It's easier to reproducer on Deployment Config with "Recreate" strategy. (To see this issue with Rolling strategy I needed to have an issue in image so pod was failing)

Version-Release number of selected component (if applicable):
OpenShift Version
    4.5.0-rc.6
Kubernetes Version
    v1.18.3+6025c28

How reproducible:
Every time, with Deployment Config with Recreate strategy.

Steps to Reproduce:
1.Go to Deployment Config page and select one deployment.
2.Click on Start Rollout button.
3.After few moments the exception is displayed.

Note: It's easier to reproducer on Deployment Config with "Recreate" strategy. (To see this issue with Rolling strategy I needed to have an issue in image so pod was failing)

Actual results:
'e is undefined' exception is thrown

Expected results:
no exception


Additional info:

Comment 3 Samuel Padgett 2020-07-28 12:50:23 UTC
*** Bug 1861116 has been marked as a duplicate of this bug. ***

Comment 6 XiaochuanWang 2020-07-31 02:33:44 UTC
Tried for several times, this is not reproduced.
Verified on 4.5.0-0.nightly-2020-07-30-020337

Comment 8 errata-xmlrpc 2020-08-10 13:50:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.5 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3188


Note You need to log in before you can comment on or make changes to this bug.