Bug 1857881 - abrt-java-connector fails to build with java-11-openjdk
Summary: abrt-java-connector fails to build with java-11-openjdk
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt-java-connector
Version: rawhide
Hardware: All
OS: All
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: Java11
TreeView+ depends on / blocked
Reported: 2020-07-16 17:32 UTC by jiri vanek
Modified: 2020-07-22 07:48 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2020-07-22 07:48:57 UTC
Type: ---

Attachments (Terms of Use)

Description jiri vanek 2020-07-16 17:32:19 UTC
abrt-java-connector fails to build with java-11-openjdk as sytem JDK. See https://fedoraproject.org/wiki/Changes/Java11 .
See especially part about known failures: https://fedoraproject.org/wiki/Changes/Java11#common_issues_packagers_can_face_and_gathered_solutions

For the build logs, see: https://koji.fedoraproject.org/koji/taskinfo?taskID=47146006
We run the rebuild longer then 10days ago. Log may be gone. Also your package may be passing in regular rawhide.
To reproduce, simply: fedpkg clone abrt-java-connector; cd abrt-java-connector;  fedpkg build --target f33-java11; #The target is crucial.

We run two reruns your package failed both.

Surprisingly, your package is passing in our initial copr - https://copr.fedorainfracloud.org/coprs/jvanek/java11/package/abrt-java-connector
That usually mean that it is jdk11 independent error, or platform (non-intel) specific failure.  Good luck.

We had tried 650 packages, and 500 had passed, so the java-11-openjdk will be system JDK in f33, and you should fix your package if you want to keep it alive. Usually the fix is simple, and best is to update the package to latest upstream version.
There will be usual mass rebuild once f33 branches. You may got another FTBFS bug.
Let us know here if you have any questions, here in bug, or at java-devel.org .

We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side if needed.

Comment 1 jiri vanek 2020-07-17 03:37:44 UTC
highlight: This was rebuild in sidetag f33-java11. Thus --target is really necessary to reproduce failure.
please note: This side tag, f33-java11, will be merged to main f33 buildroot in aprox 14 days.

Comment 2 Miroslav Suchý 2020-07-21 14:14:21 UTC
I believe this may be fixed in commit ab9cc31c84fdfdab342d5e0c1e4c0f2012588621

@ekulik can you confirm

Comment 3 ekulik 2020-07-21 14:20:16 UTC
Sure, I managed to build it: https://copr.fedorainfracloud.org/coprs/ekulik/java11/package/abrt-java-connector/

Comment 4 ekulik 2020-07-21 14:22:12 UTC
But the build was only on x86_64, so there might be something.

Comment 5 ekulik 2020-07-21 14:40:18 UTC
This makes no sense, because one of the applied patches absolutely corrects the stack traces and yet the test pulls the wrong files out of thin air.

Comment 6 ekulik 2020-07-22 07:48:57 UTC
I was hitting some CMake-related failures, but now it works: https://koji.fedoraproject.org/koji/taskinfo?taskID=47615606

Note You need to log in before you can comment on or make changes to this bug.