Bug 185797 - Support for AMD64 in 32 bit Fedora version
Support for AMD64 in 32 bit Fedora version
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gmp (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-18 03:45 EST by Juergen Bullinger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-28 08:10:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Bullinger 2006-03-18 03:45:40 EST
Description of problem:

Hi, this is not a bug, but I don't know where else I could ask this.
I use gmp on my athlon 64. Is there any way to use the 32 bit Fedora version
with the 64 bit code?
If it is possible, what would I have to do to make it compile using 64 bit code
on FC5? I guess I need a compiler capable of 64 bit code and need to change the
configure script of gmp, but are there other dependencies (e.g. dependent
libraries)?
Is gcc able to mix 32 and 64 code at all?

I would like to compile it myself, because I would like to install the x86_64
extensions by Pierrick Gaudry, or are they already included in the Fedora
version of GMP?

At the moment I use FC5 Test 3 x86_64 but I would like to switch to the 32 bit
version, because of the lack of support by vendors like macromedia (there seems
to be no possibility to install flash on a x86_64 system). The other thing is
that the 64 bit version is highly redundant because almost every library is
present in a 32 and a 64 bit version. I know that this is necessary and it also
looks as if the disadvantages of the 64 bit version are smaller and smaller with
each new Fedora release, but for the moment I would like to switch to 32 bit if
it is possible without loosing gmp computing performance.

Version-Release number of selected component (if applicable):
gmp 4.1.4


Thank you very much in advance.

Juergen
Comment 1 Juergen Bullinger 2006-03-22 05:31:42 EST
BTW: have you already seen, that the release candidate for gmp 4.2 is out on the
swox page?
It already includes some of the assembler routines. But I would still be
interested in compiling a 64 bit version of gmp in a 32 bit environment (I mean
I just want to use the 64 bit capabilities of my processor, I guess this has
nothing to do with the interface to the library, right?)
Comment 2 Juergen Bullinger 2006-03-26 12:53:20 EST
I switched to fc5 but there is also no solution yet
Comment 3 Thomas Woerner 2006-04-28 08:10:58 EDT
It is not possible to use 64bit code in 32bit environments without major changes
to the code and the environment.

Closing as "NOT A BUG".

Note You need to log in before you can comment on or make changes to this bug.