Bug 1857980 - Update arpwatch into latest upstream
Summary: Update arpwatch into latest upstream
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: arpwatch
Version: rawhide
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Ben Beasley
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1893543 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-16 19:47 UTC by Jari Turkia
Modified: 2020-11-11 18:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-11 18:45:47 UTC
Type: Bug


Attachments (Terms of Use)
Arpwatch 3.1 (644.33 KB, application/x-rpm)
2020-07-16 19:47 UTC, Jari Turkia
no flags Details

Description Jari Turkia 2020-07-16 19:47:09 UTC
Created attachment 1701462 [details]
Arpwatch 3.1

Description of problem:
Arpwatch has been in version 2.1 for years.

Version-Release number of selected component (if applicable):
arpwatch-2.1a15-46

How reproducible:
Easily, always

Steps to Reproduce:
1. Install arpwatch
2.
3.

Actual results:
Arpwatch 2.1 installed

Expected results:
Latest version of arpwatch installed

Additional info:
In current packaging /etc/sysconfig/ is not supported. Any change into runtime configuration needs to be done into .service-file.

To upgrade into latest version and introduce proper configuration, a new version is made.

Comment 1 Fedora Admin user for bugzilla script actions 2020-10-26 14:53:13 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 2 Ben Beasley 2020-10-26 19:11:07 UTC
I have just taken ownership of this package in Fedora after it was orphaned by the previous maintainer.

My first priority will be an expedited patch for https://bugzilla.redhat.com/show_bug.cgi?id=1563939, backported to the old version. After that I plan to dig into the version 3.1 update.

I want to get this update right, so it will take a little while to (1) review the upstream changes, (2) review your source rpm, (3) check all of the patches and hacks in the old package to see which are still needed, and (4) review the spec file for any needed modernization. Thank you for contributing an updated source RPM. This will be a big help. Expect to see some activity within the next few weeks.

Comment 3 Ben Beasley 2020-11-01 18:02:36 UTC
*** Bug 1893543 has been marked as a duplicate of this bug. ***

Comment 4 Ben Beasley 2020-11-11 17:10:04 UTC
I just updated Rawhide to ship the latest upstream version, 3.1; the entire spec file has been modernized and de-crufted, and I have reviewed and dropped, rebased, or rewritten every patch or extra source file carried by the Fedora package. (I will send all remaining patches and extra sources upstream for consideration prior to the release of Fedora 34; I am waiting for further testing before doing so.)

I’ve made all these changes very carefully; still, given the scope of the necessary changes, I would especially appreciate testing and feedback from any arpwatch users, as well as from anyone who feels like auditing the current spec file and/or patches (https://src.fedoraproject.org/rpms/arpwatch/tree/master).


Note You need to log in before you can comment on or make changes to this bug.