Bug 1858032 - libbluray fails to build with java-11-openjdk
Summary: libbluray fails to build with java-11-openjdk
Alias: None
Product: Fedora
Classification: Fedora
Component: libbluray
Version: rawhide
Hardware: All
OS: All
Target Milestone: ---
Assignee: Xavier Bachelot
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: Java11
TreeView+ depends on / blocked
Reported: 2020-07-16 20:50 UTC by jiri vanek
Modified: 2020-07-18 11:39 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2020-07-18 11:39:45 UTC
Type: ---

Attachments (Terms of Use)

Description jiri vanek 2020-07-16 20:50:58 UTC
libbluray fails to build with java-11-openjdk as sytem JDK. See https://fedoraproject.org/wiki/Changes/Java11 .
See especially part about known failures: https://fedoraproject.org/wiki/Changes/Java11#common_issues_packagers_can_face_and_gathered_solutions

For the build logs, see: https://koji.fedoraproject.org/koji/taskinfo?taskID=47157639
We run the rebuild longer then 10days ago. Log may be gone. Also your package may be passing in regular rawhide.
To reproduce, simply: fedpkg clone libbluray; cd libbluray;  fedpkg build --target f33-java11; #The target is crucial.

We run two reruns your package failed both.

Surprisingly, your package is passing in our initial copr - https://copr.fedorainfracloud.org/coprs/jvanek/java11/package/libbluray
That usually mean that it is jdk11 independent error, or platform (non-intel) specific failure.  Good luck.

We had tried 650 packages, and 500 had passed, so the java-11-openjdk will be system JDK in f33, and you should fix your package if you want to keep it alive. Usually the fix is simple, and best is to update the package to latest upstream version.
There will be usual mass rebuild once f33 branches. You may got another FTBFS bug.
Let us know here if you have any questions, here in bug, or at java-devel.org .

We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side if needed.

Comment 1 Xavier Bachelot 2020-07-16 22:34:54 UTC
The build is failing on s390x with the following error :
Cannot download toplink/packages/java-11-openjdk/ All mirrors were tried

I don't think that is something I can do anything about.

Comment 2 jiri vanek 2020-07-17 03:57:42 UTC
highlight: This was rebuild in sidetag f33-java11. Thus --target is really necessary to reproduce failure.
please note: This side tag, f33-java11, will be merged to main f33 buildroot in aprox 14 days.

Comment 3 Fabio Valentini 2020-07-17 09:26:54 UTC
FWIW, I submitted a scratch build for f33-java11, and it passed.
So the failure really seems to be some kind of transient networking / koji issue.

It should be safe to just resubmit a libbluray build with "fedpkg build --target f33-java11" (and if necessary, repeat until koji doesn't screw up).

Comment 4 Xavier Bachelot 2020-07-17 10:50:12 UTC
Thanks Fabio.

The  following (non-scratch) build succeeded:
Task info: https://koji.fedoraproject.org/koji/taskinfo?taskID=47341590

Jiri, shall I just close this bug now or is there anything more needed ?

Comment 5 Fabio Valentini 2020-07-18 11:39:45 UTC
This is enough. Thanks for looking into it!

PS: If possible, don't submit "normal" rawhide build of libbluray until f33-java11 is merged into rawhide.
If you need to do other updates, submit them for f33-java11 as well, please. Thank you!

Note You need to log in before you can comment on or make changes to this bug.