Bug 1858082 - rstudio fails to build with java-11-openjdk
Summary: rstudio fails to build with java-11-openjdk
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rstudio
Version: rawhide
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: Iñaki Ucar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: Java11
TreeView+ depends on / blocked
 
Reported: 2020-07-16 21:58 UTC by jiri vanek
Modified: 2020-07-18 15:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-17 18:08:45 UTC
Type: ---


Attachments (Terms of Use)

Description jiri vanek 2020-07-16 21:58:24 UTC
rstudio fails to build with java-11-openjdk as sytem JDK. See https://fedoraproject.org/wiki/Changes/Java11 .
See especially part about known failures: https://fedoraproject.org/wiki/Changes/Java11#common_issues_packagers_can_face_and_gathered_solutions

For the build logs, see: https://koji.fedoraproject.org/koji/taskinfo?taskID=47162014
We run the rebuild longer then 10days ago. Log may be gone. Also your package may be passing in regular rawhide.
To reproduce, simply: fedpkg clone rstudio; cd rstudio;  fedpkg build --target f33-java11; #The target is crucial.

We run two reruns your package failed both.

Surprisingly, your package is passing in our initial copr - https://copr.fedorainfracloud.org/coprs/jvanek/java11/package/rstudio
That usually mean that it is jdk11 independent error, or platform (non-intel) specific failure.  Good luck.
              

We had tried 650 packages, and 500 had passed, so the java-11-openjdk will be system JDK in f33, and you should fix your package if you want to keep it alive. Usually the fix is simple, and best is to update the package to latest upstream version.
There will be usual mass rebuild once f33 branches. You may got another FTBFS bug.
Let us know here if you have any questions, here in bug, or at java-devel@lists.fedoraproject.org .

We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side if needed.

Comment 1 Iñaki Ucar 2020-07-16 22:17:19 UTC
I only see one rebuild, and failed before the build started in one arch (due to a repo error), and then was cancelled for the rest of the arches. The package builds just fine with Java 11.

Comment 2 jiri vanek 2020-07-17 03:28:03 UTC
Are you sure Inaki? Due t our chat on the begging of java11 proposal, I was watching rstudio namely, and was surprised it fails on non intels.  Anyway, happy to see this closed:) TYVM!

Comment 3 jiri vanek 2020-07-17 04:10:05 UTC
highlight: This was rebuild in sidetag f33-java11. Thus --target is really necessary to reproduce failure.
please note: This side tag, f33-java11, will be merged to main f33 buildroot in aprox 14 days.

Comment 4 jiri vanek 2020-07-17 04:27:11 UTC
The second rebuild overrides failures of first one. that's why you do can not find it in koji. Only digging in dates would suggest it.
I had started another build in side tag for you: https://koji.fedoraproject.org/koji/taskinfo?taskID=47330918

Comment 5 jiri vanek 2020-07-17 05:09:23 UTC
...and it failed again:( Now on intel32. there is really something wrong.

Comment 6 Iñaki Ucar 2020-07-17 07:43:38 UTC
(In reply to jiri vanek from comment #4)
> I had started another build in side tag for you:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=47330918

Ok, *this* is a build failure, and not what you linked in the initial message.

(In reply to jiri vanek from comment #0)
> We run the rebuild longer then 10days ago.

(In reply to jiri vanek from comment #3)
> please note: This side tag, f33-java11, will be merged to main f33 buildroot
> in aprox 14 days.

Then why wasn't this reported *10 days ago*?

Comment 7 Iñaki Ucar 2020-07-17 08:31:08 UTC
Succeeded in i686: https://koji.fedoraproject.org/koji/taskinfo?taskID=47337946. Can you cancel the task 47330918, please?

Comment 8 Iñaki Ucar 2020-07-17 18:08:45 UTC
Built successfully, didn't touch anything: https://koji.fedoraproject.org/koji/taskinfo?taskID=47339855

Comment 9 jiri vanek 2020-07-18 14:55:09 UTC
(In reply to Iñaki Ucar from comment #6)
> (In reply to jiri vanek from comment #4)
> > I had started another build in side tag for you:
> > https://koji.fedoraproject.org/koji/taskinfo?taskID=47330918
> 
> Ok, *this* is a build failure, and not what you linked in the initial
> message.

https://koji.fedoraproject.org/koji/taskinfo?taskID=47162014 failed to. On s390x due to missing dependence.  The one before I do not have linka handy now failed because of compilation erroro on aarch64 as  *this* on i686.

> 
> (In reply to jiri vanek from comment #0)
> > We run the rebuild longer then 10days ago.
> 
> (In reply to jiri vanek from comment #3)
> > please note: This side tag, f33-java11, will be merged to main f33 buildroot
> > in aprox 14 days.
> 
> Then why wasn't this reported *10 days ago*?

Sorry. I did not managed to fill it asap, and then I had to leave virtual world for a while:( That was really unintentional.  you could have got email about failed build in that time, and I had filled the bugs immediately when I was back online.

Comment 10 jiri vanek 2020-07-18 15:00:02 UTC
(In reply to Iñaki Ucar from comment #8)
> Built successfully, didn't touch anything:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=47339855

I'm happy to hear that it is ok!  Still the issues I saw it fail for on non intels are scary. There may be bug in jdk, or in native parts of rstudio or in gcc or JS interpreter. Thsoe bugs are usually very hard to catch, so  it is just positive that it is now built.
If you encounter non intel arch fail again, I would encourage you to look into it, and try to fill a bug report to possible component.

Comment 11 Iñaki Ucar 2020-07-18 15:04:43 UTC
It seems to me like some kind of race condition in the gwt building process. As long as it succeeds, I don't care so much, because once this is compiled, RStudio itself doesn't require Java at all.


Note You need to log in before you can comment on or make changes to this bug.