This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 185812 - The man page for restorecon doesn't document whether sym links are followed.
The man page for restorecon doesn't document whether sym links are followed.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-18 13:19 EST by Bruno Wolff III
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-24 00:54:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2006-03-18 13:19:17 EST
Description of problem:
The man page for restorecon doesn't say how -R behaves when there are sym links.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. man restorecon
2.
3.
  
Actual results:


Expected results:


Additional info:
It looks like there is a changelog entry indicating that restorecon isn't
supposed to follow symlinks and/or apply changes to targets of sym links.
Comment 1 Daniel Walsh 2006-03-20 14:46:23 EST
restorecon will not follow symbolic links.
Comment 2 Daniel Walsh 2006-05-23 23:48:15 EDT
Fixed in rawhide.
Comment 3 Kevin Fenzi 2007-03-24 00:54:41 EDT
I can confirm that the man page has a note that it does NOT follow symbolic links. 

Closing this bug out. If you see any further problem with it, feel free to
re-open or file a new bug against the latest version. 

Note You need to log in before you can comment on or make changes to this bug.