Bug 185822 - "Permission denied" after cd /boot on a Xen guest
"Permission denied" after cd /boot on a Xen guest
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-18 15:36 EST by Pete Zaitcev
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 5.0.33-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 18:22:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Candidate fix with "return" instead of "continue 2" (1.69 KB, patch)
2006-03-18 15:36 EST, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Pete Zaitcev 2006-03-18 15:36:05 EST
Description of problem:

[root@xen-card boot]# ls
config-2.6.15-1.1955_FC5guest      mkinitrd.diff
grub                               System.map-2.6.15-1.1955_FC5guest
initrd-2.6.15-1.1955_FC5guest.img  System.map-2.6.15-1.2054_FC5.z1
lost+found                         vmlinuz-2.6.15-1.1955_FC5guest
mkinitrd                           vmlinuz-2.6.15-1.2054_FC5.z1
[root@xen-card boot]# ls /lib/modules
2.6.15-1.1955_FC5guest  2.6.15-1.2054_FC5.z1
[root@xen-card boot]# mkinitrd initrd-2.6.15-1.2054_FC5.z1.img 2.6.15-1.2054_FC5.z1
/sbin/mkinitrd: line 975: initrd-2.6.15-1.2054_FC5.z1.img: Permission denied
[root@xen-card boot]# 

Version-Release number of selected component (if applicable):

[root@xen-card boot]# rpm -q mkinitrd
mkinitrd-5.0.32-1

How reproducible:

100% under given conditions

Steps to Reproduce:
0. Create a standard Xen guest with /usr/sbin/xenguest-install.py
1. Boot into the Xen guest
2. Build a custom kernel
3. make modules_install
4. cp vmlinu* /boot  (well, has to have good names, see above)
5. Run mkinitrd as above

Actual results:

"Permission denied" message

Expected results:

Normal compressed cpio image

Additional info:

The problem is caused by unbalanced pushd, so mkinitd attempts to create
the image inside sysfs. Running with a full path argument works around it.

This problem may be present outside of Xen, just latent due to different
boot devices or other layout differences.

Please see the patch (to be attached).
Comment 1 Pete Zaitcev 2006-03-18 15:36:05 EST
Created attachment 126313 [details]
Candidate fix with "return" instead of "continue 2"
Comment 2 Peter Jones 2006-03-23 21:14:46 EST
Ok, this is committed in CVS; it'll be in the package next time I do a rawhide
build.

Note You need to log in before you can comment on or make changes to this bug.