Bug 185829 - Compiling bind-9.3.1-14_FC4.src.rpm on non-fedora system
Compiling bind-9.3.1-14_FC4.src.rpm on non-fedora system
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-18 19:43 EST by Penelope Fudd
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: bind-9.3.1-16_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-19 13:19:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to fix it. (337 bytes, patch)
2006-03-18 19:43 EST, Penelope Fudd
no flags Details | Diff

  None (edit)
Description Penelope Fudd 2006-03-18 19:43:09 EST
Description of problem:
Compiling the source RPM on a system without DBUS fails, because %patch25 isn't
wrapped in %if %{WITH_DBUS}/%endif

Version-Release number of selected component (if applicable):
bind-9.3.1-14_FC4.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh bind-9.3.1-14_FC4.src.rpm
2. cd /usr/src/redhat/SPECS
3. rpmbuild -ba --define "WITH_DBUS 0" bind.spec
  
Actual results:
Prep stage fails; patch asks to patch files that aren't there.

Expected results:
Smooth, easy compile.

Additional info:
This is on a CentOS release 3.6 system; dbus is not present.
Comment 1 Penelope Fudd 2006-03-18 19:43:09 EST
Created attachment 126317 [details]
Patch to fix it.
Comment 2 Jason Vas Dias 2006-03-19 13:19:10 EST
Yes, this was one of the issues fixed by bind-9.3.1-16_FC4, now in FC-4/Updates:
ftp://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/4/SRPMS/bind-9.3.1-16_FC4.src.rpm


Note You need to log in before you can comment on or make changes to this bug.