Bug 18583 - Retail RH 7 standard installation fails after creating file system
Retail RH 7 standard installation fails after creating file system
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 22:47 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 11:41:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-06 22:47:27 EDT
This is the EXACT same system AND hard drive onto which RH 6.2 retail
standard was recently installed successfully.  I was doing a complete
reinstall (not an upgrade).   The system briefly is: 800Mhz EB coppermine
PIII flip-chip PPGA CPU, 256MB pc133 DIMM RAM, 61.4GB maxtor diamondmax 60
EIDE ATA66/ATA100 drive, DVD-ROM/CD-ROM, floppy, ASUS CUSL2 MB, intel 815E
chipset.  To repeat, RH6.2 installed without any issues on this system.

Checked the errata and there are no install errata at this time.  Tried the
install from CDROM boot and floppy boot, in text and GUI mode, all attempts
were in expert mode with "custom" selected.

The RH 7.0 anaconda program in text or GUI mode encountered an exceptional 
condition during install right after completing the file system creation
step.  The dialog box said it is probably a bug and to report it using
bugzilla.redhat.com.  I chose the save option and this is the text that
was saved to the floppy:

  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
doInstall
    if self.method.systemMounted (self.fstab, self.instPath,
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] +
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' +
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//win2k

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-10-09 11:41:04 EDT
We are about to release an errata for this.

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.