Bug 1858317 - NetworkAttachmentDefinition VLAN attribute has invalid type
Summary: NetworkAttachmentDefinition VLAN attribute has invalid type
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Phillip Bailey
QA Contact: Guohua Ouyang
URL:
Whiteboard:
: 1888987 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-17 14:13 UTC by Petr Horáček
Modified: 2020-10-27 16:16 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:15:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6210 0 None closed Bug 1858317: Change type of VLAN attribute for CNV bridge in NADs 2020-10-22 16:22:41 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:16:18 UTC

Description Petr Horáček 2020-07-17 14:13:24 UTC
Description of problem:
NetworkAttachmentDefinition for bridge CNI keeps VLAN ID in an invalid format.


Version-Release number of selected component (if applicable):
CNV 2.4


How reproducible:
Always


Steps to Reproduce:
1. Create a NetworkAttachmentDefinition of type bridge and with a VLAN ID
2. Check the generated YAML


Actual results:
"vlan" has value of type string.


Expected results:
"vlan" should have value of type integer.


Additional info:

Comment 3 Guohua Ouyang 2020-09-04 02:13:52 UTC
verified on master

Comment 4 Petr Horáček 2020-10-22 16:24:43 UTC
*** Bug 1888987 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2020-10-27 16:15:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.