This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 185860 - xenguest-install.py should support multiple NICs and multiple disks
xenguest-install.py should support multiple NICs and multiple disks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brian Brock
: FutureFeature
Depends On:
Blocks: FC5Update
  Show dependency treegraph
 
Reported: 2006-03-19 17:41 EST by Ben
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-11 16:23:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xenguest-install.py that supports the requested features (13.29 KB, text/plain)
2006-03-19 17:41 EST, Ben
no flags Details

  None (edit)
Description Ben 2006-03-19 17:41:36 EST
When installing a new domU, xenguest-install.py should be able to format a xen
config file that supports multiple NICs and multiple disks. Attached is a
version that does just that.
Comment 1 Ben 2006-03-19 17:41:36 EST
Created attachment 126329 [details]
xenguest-install.py that supports the requested features
Comment 2 Jeremy Katz 2006-09-25 16:46:16 EDT
xenguest-install has been rewritten a bit and the backend code definitely
supports multiple disks/nics now.  The difficult part is how to handle it via
the command line; asking for more than one in the asking questions form of
xenguest-install is going to be very error-prone.  
Comment 3 Daniel Berrange 2007-01-11 16:23:14 EST
In FC6 and later, xenguest-install.py is replaced by the python-virtinst RPM.
The 0.98.0-1.fc6 release of python-virtinst contains support for multiple nics /
disks. There are no plans to add this in FC5 or earlier because they used the
legacy xenguest-install.py script.

Note You need to log in before you can comment on or make changes to this bug.