Bug 1858667 - [OpenStack] Got `panic: runtime error: invalid memory address or nil pointer dereference` when create manifests
Summary: [OpenStack] Got `panic: runtime error: invalid memory address or nil pointer ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Martin André
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-20 02:30 UTC by weiwei jiang
Modified: 2020-10-27 16:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:15:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3915 0 None closed OpenStack: fix runtime error with machine pool validation 2020-12-29 04:14:56 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:16:18 UTC

Description weiwei jiang 2020-07-20 02:30:14 UTC
Description of problem: 
When trying to create manifests, got a panic error. 
 
Version-Release number of the following components: 
registry.svc.ci.openshift.org/ocp/release:4.6.0-0.nightly-2020-07-19-073020 
 
$ ./openshift-install-4.6.0-0.nightly-2020-07-19-073020 version 
./openshift-install-4.6.0-0.nightly-2020-07-19-073020 4.6.0-0.nightly-2020-07-19-073020 
built from commit 84cb23d2b19c2fce1ae582c0c27cbb351cdc8aea 
release image registry.svc.ci.openshift.org/ocp/release@sha256:b0600325129b5b14d272ad61bcbd7fe609b812ac2620976158046a7bd2c31c62 
 
 and 
 
$ ./openshift-install 4.6.0-0.nightly-2020-07-18-160600
built from commit 84cb23d2b19c2fce1ae582c0c27cbb351cdc8aea
release image upshift.mirror-registry.qe.devcluster.openshift.com:5000/ocp/release@sha256:28166a3bcc7c173208d24d4df45f3790b672c4a671e99b42b616363bdb1fb111

also
$ ./openshift-install-4.6 version                                                                                                                                                                                                                                  
./openshift-install-4.6 4.6.0-0.nightly-2020-07-19-093912
built from commit 84cb23d2b19c2fce1ae582c0c27cbb351cdc8aea
release image registry.svc.ci.openshift.org/ocp/release@sha256:cb649ba27911b7f4a493aeb950e1605d32fa95cf86074233cf432ec96076e5e5

How reproducible: 
Always 
 
Steps to Reproduce: 
1. setup openstack creds and pull-secrets to generate the install-config.yaml 
2. try to do `openshift-install create manifests --dir <xxx> --log-level debug` 
3. 
 
Actual results: 
$ ./openshift-install-4.6.0-0.nightly-2020-07-19-073020 create manifests --dir . --log-level debug                                                                                                                                                                                                                
DEBUG OpenShift Installer 4.6.0-0.nightly-2020-07-19-073020                                                                                                                                                                                                                                                                   
DEBUG Built from commit 84cb23d2b19c2fce1ae582c0c27cbb351cdc8aea                                                                                                                                                                                                                                                              
DEBUG Fetching Master Machines...                                                                                                                                                                                                              
DEBUG Loading Master Machines...                                                                                        
DEBUG   Loading Cluster ID...                                                                                                                                                                                                                  
DEBUG     Loading Install Config...                                                                                     
DEBUG       Loading SSH Key...                                                                                                                                                                                                                 
DEBUG       Loading Base Domain...                                                                                      
DEBUG         Loading Platform...                                                                                                                                                                                                              
DEBUG       Loading Cluster Name...                                                                                     
DEBUG         Loading Base Domain...                                                                                                                                                                                                           
DEBUG         Loading Platform...                                                                                       
DEBUG       Loading Pull Secret...                                                                                                                                                                                                             
DEBUG       Loading Platform...                                                                                         
panic: runtime error: invalid memory address or nil pointer dereference                                                                                                                                                                        
[signal SIGSEGV: segmentation violation code=0x1 addr=0x10 pc=0x20492a7]                                                
                                                                                                                                                                                                                                               
goroutine 1 [running]:                                                                                                  
github.com/openshift/installer/pkg/asset/installconfig/openstack/validation.validateMachinePool(0x0, 0xc00021d530, 0xc000dd0f60, 0x2, 0x2)                                                                                                     
        /go/src/github.com/openshift/installer/pkg/asset/installconfig/openstack/validation/machinepool.go:15 +0x37                                                                                                                                                              
github.com/openshift/installer/pkg/asset/installconfig/openstack/validation.Validate(0xc00054fc00, 0x0, 0x0)                                                                                                                                                                     
        /go/src/github.com/openshift/installer/pkg/asset/installconfig/openstack/validation/validation.go:19 +0x177     
github.com/openshift/installer/pkg/asset/installconfig/openstack.Validate(...)                                                                                                                                                                                                                                                
        /go/src/github.com/openshift/installer/pkg/asset/installconfig/openstack/openstack.go:18                                                                                                                                                                                                                              
github.com/openshift/installer/pkg/asset/installconfig.(*InstallConfig).platformValidation(0xc000a18380, 0x0, 0x0)                                                                                                                                                                                                            
        /go/src/github.com/openshift/installer/pkg/asset/installconfig/installconfig.go:188 +0x82                                                              
github.com/openshift/installer/pkg/asset/installconfig.(*InstallConfig).finish(0xc000a18380, 0xcf1ea34, 0x13, 0x3149, 0xcc457c0)                                                                                                                                                                                              
        /go/src/github.com/openshift/installer/pkg/asset/installconfig/installconfig.go:148 +0x228                                                             
github.com/openshift/installer/pkg/asset/installconfig.(*InstallConfig).Load(0xc000a18380, 0xe65e280, 0xc0000ac520, 0xe75ae80, 0xc000a18380, 0xc000a18380)                                                                                                                                                                    
        /go/src/github.com/openshift/installer/pkg/asset/installconfig/installconfig.go:125 +0x1e7                                                             
github.com/openshift/installer/pkg/asset/store.(*storeImpl).load(0xc000a087e0, 0xe68be40, 0xc0005ebf40, 0xc0009fa448, 0x4, 0xc0009fa448, 0x4, 0x0)                                                                                                                                                                            
        /go/src/github.com/openshift/installer/pkg/asset/store/store.go:264 +0x440                                                                             
github.com/openshift/installer/pkg/asset/store.(*storeImpl).load(0xc000a087e0, 0xe68be00, 0xc0005ebea0, 0xceb2964, 0x2, 0xceb2964, 0x2, 0x0)                                                                                                                                                                                  
        /go/src/github.com/openshift/installer/pkg/asset/store/store.go:247 +0x2c7                                                                             
github.com/openshift/installer/pkg/asset/store.(*storeImpl).load(0xc000a087e0, 0xe68c180, 0x16030280, 0x0, 0x0, 0x2, 0x2, 0xe5d0c00)                                                                                                                                                                                          
        /go/src/github.com/openshift/installer/pkg/asset/store/store.go:247 +0x2c7                                                                             
github.com/openshift/installer/pkg/asset/store.(*storeImpl).fetch(0xc000a087e0, 0xe68c180, 0x16030280, 0x0, 0x0, 0x40a4f5, 0xb9c3ee0)                                                                                                                                                                                         
        /go/src/github.com/openshift/installer/pkg/asset/store/store.go:201 +0xa1d                                                                             
github.com/openshift/installer/pkg/asset/store.(*storeImpl).Fetch(0xc000a087e0, 0xe68c180, 0x16030280, 0x15fea4e0, 0x4, 0x4, 0x3700000000000000, 0xed6a6f41d)                                                                                                                                                                 
        /go/src/github.com/openshift/installer/pkg/asset/store/store.go:77 +0x4b                                                                               
main.runTargetCmd.func1(0x7ffcf5acbdf4, 0x1, 0xc0005ebdc0, 0xc000a085a0)                                                                                       
        /go/src/github.com/openshift/installer/cmd/openshift-install/create.go:172 +0x133                                                                      
main.runTargetCmd.func2(0x15ff5340, 0xc0009159c0, 0x0, 0x4)                                                                                                    
        /go/src/github.com/openshift/installer/cmd/openshift-install/create.go:199 +0xb2                                                                       
github.com/spf13/cobra.(*Command).execute(0x15ff5340, 0xc000915980, 0x4, 0x4, 0x15ff5340, 0xc000915980)                                                        
        /go/src/github.com/openshift/installer/vendor/github.com/spf13/cobra/command.go:844 +0x29d                                                             
github.com/spf13/cobra.(*Command).ExecuteC(0xc0000298c0, 0xc0009ede58, 0x1, 0x1)                                                                               
        /go/src/github.com/openshift/installer/vendor/github.com/spf13/cobra/command.go:945 +0x317                                                                                                                                                                                                                            
github.com/spf13/cobra.(*Command).Execute(...)                                  
        /go/src/github.com/openshift/installer/vendor/github.com/spf13/cobra/command.go:885                                                                    
main.installerMain()                                                                                                                                                                                                                                                                                                          
        /go/src/github.com/openshift/installer/cmd/openshift-install/main.go:63 +0x2b3                                                                         
main.main()                                                                                                                                                                                                                                                                                                                   
        /go/src/github.com/openshift/installer/cmd/openshift-install/main.go:43 +0xc6          
 
Expected results: 
Should work well. 
 
Additional info: 
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 Martin André 2020-07-20 13:09:29 UTC
The fix for this issue has just merged in https://github.com/openshift/installer/pull/3915.

Comment 6 David Sanz 2020-07-20 17:02:24 UTC
Verified on 4.6.0-0.nightly-2020-07-20-163249

Comment 9 errata-xmlrpc 2020-10-27 16:15:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.