Bug 1858871 - Unit test TestGetReclaimableThreshold is failing very frequently in CI
Summary: Unit test TestGetReclaimableThreshold is failing very frequently in CI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.6.0
Assignee: Seth Jennings
QA Contact: Weinan Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-20 16:11 UTC by Venkata Siva Teja Areti
Modified: 2020-10-27 16:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:16:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kubernetes pull 295 0 None closed BUG 1858871: UPSTREAM: 93478: kubelet: eviction: remove unexpected output from TestGetReclaimableThreshold 2020-08-31 14:06:05 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:16:31 UTC

Description Venkata Siva Teja Areti 2020-07-20 16:11:01 UTC
Description of problem:
Unit test TestGetReclaimableThreshold is failing very frequently in CI. 

https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/openshift_kubernetes/263/pull-ci-openshift-kubernetes-master-unit/1285216748374593536
https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/openshift_kubernetes/263/pull-ci-openshift-kubernetes-master-unit/1285201955584479232

Version-Release number of selected component (if applicable):


How reproducible:
Most of the time

Steps to Reproduce:
1. 
2.
3.

Actual results:
unit test fails

Expected results:
unit test must pass


Additional info:

Comment 1 Seth Jennings 2020-07-27 18:51:07 UTC
I think the printing of the threshold name is throwing off the results parser
https://github.com/kubernetes/kubernetes/pull/78624/files#diff-d1674863b3df010b8b90a347f6bec9b2R95

Comment 2 Seth Jennings 2020-07-27 18:57:21 UTC
Upstream PR https://github.com/kubernetes/kubernetes/pull/93478

Comment 6 Weinan Liu 2020-08-31 15:52:52 UTC
@Seth, I see it's a UT issue, may I ask where I can get the latest UT result?

Comment 8 Weinan Liu 2020-09-01 08:54:19 UTC
Issue got fixed basing on comment 7.
TestGetReclaimableThreshold failure did not happen in the most recent UT result.

Comment 10 errata-xmlrpc 2020-10-27 16:16:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.