Bug 1859156 - "http: server gave HTTP response to HTTPS client" for thanos-ruler endpoints
Summary: "http: server gave HTTP response to HTTPS client" for thanos-ruler endpoints
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Simon Pasquier
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-21 11:04 UTC by Junqi Zhao
Modified: 2020-10-27 16:16 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:16:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
openshift-user-workload-monitoring dump file (294.24 KB, application/gzip)
2020-07-21 11:04 UTC, Junqi Zhao
no flags Details
"http: server gave HTTP response to HTTPS client" for thanos-ruler endpoints (94.90 KB, image/png)
2020-07-21 11:05 UTC, Junqi Zhao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 872 0 None closed Bug 1859156: set listenLocal for Thanos ruler 2021-02-17 03:08:21 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:16:46 UTC

Description Junqi Zhao 2020-07-21 11:04:17 UTC
Created attachment 1701878 [details]
openshift-user-workload-monitoring dump file

Description of problem:
enabled UserWorkload
*************************
apiVersion: v1
kind: ConfigMap
metadata:
  name: cluster-monitoring-config
  namespace: openshift-monitoring
data:
  config.yaml: |
    enableUserWorkload: true
*************************
see from the prometheus /targets page, "http: server gave HTTP response to HTTPS client" for thanos-ruler endpoints
# token=`oc sa get-token prometheus-k8s -n openshift-monitoring`
# oc -n openshift-monitoring exec -c prometheus prometheus-k8s-0 -- curl -k -g -H "Authorization: Bearer $token" 'https://10.128.2.16:10902/metrics'
curl: (35) SSL received a record that exceeded the maximum permissible length.
command terminated with exit code 35

# oc -n openshift-monitoring exec -c prometheus prometheus-k8s-0 -- curl -k -g -H "Authorization: Bearer $token" 'http://10.128.2.16:10902/metrics' | head
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0# HELP go_gc_duration_seconds A summary of the pause duration of garbage collection cycles.
# TYPE go_gc_duration_seconds summary
go_gc_duration_seconds{quantile="0"} 9.913e-06
go_gc_duration_seconds{quantile="0.25"} 3.5879e-05
go_gc_duration_seconds{quantile="0.5"} 4.1316e-05
go_gc_duration_seconds{quantile="0.75"} 4.586e-05
go_gc_duration_seconds{quantile="1"} 0.005978851
go_gc_duration_seconds_sum 0.031030653
go_gc_duration_seconds_count 224
# HELP go_goroutines Number of goroutines that currently exist.


Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-07-20-183524

How reproducible:
always

Steps to Reproduce:
1. see the description
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Junqi Zhao 2020-07-21 11:05:05 UTC
Created attachment 1701880 [details]
"http: server gave HTTP response to HTTPS client" for thanos-ruler endpoints

Comment 7 Junqi Zhao 2020-07-24 03:06:34 UTC
issue is fixed with 4.6.0-0.nightly-2020-07-23-194834, thanos-ruler endpoints are UP
# oc -n openshift-user-workload-monitoring get thanosruler/user-workload -oyaml | grep listenLocal
  listenLocal: true

Comment 9 errata-xmlrpc 2020-10-27 16:16:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.