Bug 1859256 - Blankpage when using search on imagemanifestvuln resource
Summary: Blankpage when using search on imagemanifestvuln resource
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: ralpert
QA Contact: Yanping Zhang
URL:
Whiteboard:
Depends On:
Blocks: 1870825
TreeView+ depends on / blocked
 
Reported: 2020-07-21 14:54 UTC by amobrem
Modified: 2020-10-27 16:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The component was using props.match.params.ns, which was sometimes undefined. Consequence: As a result, there was a runtime error. Fix: I updated it to to use the namespace prop instead in line with other components. Result: The bug is fixed.
Clone Of:
Environment:
Last Closed: 2020-10-27 16:16:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6119 0 None closed Bug 1859256: Fix blank page/error on ImageManifestVulnPage 2020-09-21 13:35:27 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:16:46 UTC

Description amobrem 2020-07-21 14:54:51 UTC
Description of problem:

Blankpage when using search on imagemanifestvuln resource
Version-Release number of selected component (if applicable):


How reproducible:
Easily


Steps to Reproduce:
1.Go to search page
2.Select ImageManifestVuln
3.Pages becomes blank


Actual results:
blank page

Expected results:
list view of imagemanifestvuln resource

Additional info:

Comment 1 Samuel Padgett 2020-07-21 15:51:01 UTC
I can reproduce:

can't access property "params", props.match is undefined

ImageManifestVulnPage
  container-security-7233c3f0427db94c9680.js:320:22

Comment 2 ralpert 2020-07-31 17:54:14 UTC
Came up with fix for runtime error, but need to investigate better ways to use namespace. I did a quick search earlier this week and didn't see anything, but I'll keep looking next sprint.

Comment 3 ralpert 2020-08-20 15:27:15 UTC
I have a fix for this in a PR; just figuring out an integration test issue. Then I just need a review.

Comment 6 Yanping Zhang 2020-09-04 12:59:40 UTC
Checked on ocp 4.6 cluster with payload 4.6.0-0.nightly-2020-09-03-191144.
1.Install container security operator in cluster, 
2.Go to search page
3.Select ImageManifestVuln, could search successfully, there is no blank page now.
The bug is fixed.

Comment 8 errata-xmlrpc 2020-10-27 16:16:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.