Bug 1859279 - OperatorHub: Accessibility warning when clicking on tile to open modal
Summary: OperatorHub: Accessibility warning when clicking on tile to open modal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Jessica Forrester
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-21 15:47 UTC by Samuel Padgett
Modified: 2020-10-27 16:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.ci-2020-07-21-054552 Cluster ID: 187e580c-f67e-49ee-b8ef-5b76cbf8e85b Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:79.0) Gecko/20100101 Firefox/79.0
Last Closed: 2020-10-27 16:16:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6058 0 None closed Bug 1859279: Add aria-labelledby for the operator hub catalog item modal 2020-07-29 08:36:08 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:17:00 UTC

Description Samuel Padgett 2020-07-21 15:47:41 UTC
Steps to reproduce:

1. Go to Operators -> OperatorHub
2. Click on one of the tiles.

You see this warning in dev tools:

Modal: When using hasNoBodyWrapper or setting a custom header, ensure you assign an accessible name to the the modal container with aria-label or aria-labelledby. 
Modal@http://localhost:9000/static/vendors~main-e05d4c24d8d7b93c9616.js:14640:9
OperatorHubTileView@http://localhost:9000/static/operator-hub-9f4621a5e0ba0c5502cc.js:733:76
div

Opening as medium severity since this likely indicates an accessibility issue.

Comment 3 Yanping Zhang 2020-07-29 09:04:00 UTC
Checked on OCP 4.6 cluster with payload 4.6.0-0.nightly-2020-07-25-091217
Go to operator hub page, click open one catalog tile, check the modal element, there is 'aria-labelledby="catalog-item-header"' for modal, and there is 'id="catalog-item-header"' for modal header.
The bug is fixed.

Comment 5 errata-xmlrpc 2020-10-27 16:16:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.