Bug 185929 - Indirect GLX fails at X_GLXMakeCurrent with GLXBadContext
Indirect GLX fails at X_GLXMakeCurrent with GLXBadContext
Status: CLOSED DUPLICATE of bug 190245
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-19 20:02 EST by Nicholas Miell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 08:32:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicholas Miell 2006-03-19 20:02:18 EST
Running any GL app with LIBGL_ALWAYS_INDIRECT=1 results in the following:

[nicholas@entropy ~]$ LIBGL_ALWAYS_INDIRECT=1 glxinfo
name of display: :0.0
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  16
  Current serial number in output stream:  16
[nicholas@entropy ~]$

Direct rendering works fine.

mesa-libGL-(none):6.4.2-6.x86_64
mesa-libGL-(none):6.4.2-6.i386
xorg-x11-server-Xorg-(none):1.0.1-8.x86_64
xorg-x11-drv-ati-(none):6.5.7.3-4.x86_64
Comment 1 Mike A. Harris 2006-06-26 07:50:13 EDT

*** This bug has been marked as a duplicate of 190245 ***
Comment 2 Fedora Update System 2006-06-26 19:03:08 EDT
mesa-6.4.2-6.FC5.3 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 Nicholas Miell 2006-06-27 01:20:52 EDT
[nicholas@entropy ~]$ rpm -qa --nevra mesa* | sort
mesa-debuginfo-(none):6.4.2-6.FC5.3.x86_64
mesa-libGL-devel-(none):6.4.2-6.FC5.3.x86_64
mesa-libGL-(none):6.4.2-6.FC5.3.i386
mesa-libGL-(none):6.4.2-6.FC5.3.x86_64
mesa-libGLU-devel-(none):6.4.2-6.FC5.3.x86_64
mesa-libGLU-(none):6.4.2-6.FC5.3.i386
mesa-libGLU-(none):6.4.2-6.FC5.3.x86_64
mesa-libGLw-devel-(none):6.4.2-6.FC5.3.x86_64
mesa-libGLw-(none):6.4.2-6.FC5.3.x86_64

[nicholas@entropy ~]$ LIBGL_ALWAYS_INDIRECT=1 glxgears
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  21
  Current serial number in output stream:  21

Comment 4 Mike A. Harris 2006-06-27 08:32:02 EDT
This is a duplicate of bug #190245.  Don't reopen it.  CC yourself on the
other bug that is tracking the issue.

The reason the problem still exists is that both mesa _and_ the X server
have to be rebuilt and released.  We rebuilt and released mesa, however
the X server has been slightly delayed due to unexpected problems that
have arisen.  The X server will be released shortly to complete the fix
for this problem, and bug #190245 will be updated at that time as well.


*** This bug has been marked as a duplicate of 190245 ***
Comment 5 Fedora Update System 2006-06-28 09:47:28 EDT
mesa-6.4.2-6.FC5.3 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.