Bug 185930 - anaconda --rootpath does not restrict itself to rootpath
anaconda --rootpath does not restrict itself to rootpath
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-03-19 20:23 EST by Jane Dogalt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 15:18:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 185830 None None None Never

  None (edit)
Description Jane Dogalt 2006-03-19 20:23:15 EST
Description of problem:

Under the assumption that anaconda --rootpath should only be modifying the
contents of rootpath (not other files or state on the host system), there are at
least 3 bugs currently breaking this behavior.

- reconfigures host network
- reconfigures host timezone
- leaves a couple symlinks in /etc.

See kadischi bug 185830 for complete details


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jane Dogalt 2006-04-04 02:27:17 EDT
I'm pretty sure I've at least tracked down the timezone part of this bug-

grepping for localtime in /usr/lib/anaconda/*.py, I see that /etc/localtime gets
written in two places.

in timezone.py, the target installed system's localtime (I.E. instPath +
"/localtime) gets set

iutil.copyFile(fromFile, instPath + "/etc/localtime")

That is as it should be.  The problem however is in packages.py in
setupTimezone, where this happens (note lack of instPath)

            iutil.copyFile(tzfile, "/etc/localtime")

There is already a fallthrough in setupTimezone for testing, i.e.    

# dont do this in test mode!
    if flags.test:
        return

The problem is that this is definately a bad thing to do in --rootpath mode when
rootpath mode is used by kadischi to generate a livecd.  I'm guessing this is a
bad thing to do in rootpath mode in general, but I don't know the anaconda
userbase well enough to say for certain.

I suppose it might be too much to ask for a reference to a design spec which
would define what exactly rootpath should and should not be doing and/or used
for?  I'm just wondering how closely rootpath maps to what kadischi is using it
for, and if another option is necessary.
Comment 2 Jeremy Katz 2006-04-26 15:18:17 EDT
Fixed all of the cases caught here.  If you notice anything else, file them and
I'll take care of them.

Note You need to log in before you can comment on or make changes to this bug.