This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 185935 - Selections not highlighted during install in console text mode RH4 U3
Selections not highlighted during install in console text mode RH4 U3
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: misc (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Baker
Kevin Baker
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-20 00:38 EST by Kalim Jacobs
Modified: 2014-12-01 18:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:52:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kalim Jacobs 2006-03-20 00:38:40 EST
Description of problem:
When I make selections in during install they are not highlighted in anyway.  
It is difficult to see what is selected.  Hopefully I can attach screen shots 
some of the different consoles (terminal emulators) I tried.


I wouldn't expect hpterm to work.  It uses different   
control sequences than VT100.  Most terminal emulators,   
including xterm, are VT100-compatible.   
  
The installer doesn't highlight the selected item, but  
it does position the cursor at the selection.  In your  
screenshots, the putty and xterm windows show the cursor  
on the "OK" button.  
  
Looking at a console log of the language selection screen,  
it shows  
  
  ...  
  ESC[13;20H|       Danish  
  ESC[14;20H|       Dutch  
  ESC[15;20H|       English  
  ...  
  ESC[15;28H  
  
which paints the last three menu options and positions  
the cursor on the "E" of "English".  "ESC[<row>;<col>H"  
is the standard VT100 cursor positioning sequence (see  
http://rtfm.etla.org/xterm/ctlseq.html).  
  
The Windows command window has the worst problem, because  
you can't even see the cursor.  Does it make any difference  
if you change the cursor size (on the properties/options tab)? 
I tried using a Windows command window, but couldn't get it 
to work at all (arrow keys don't work, etc). 
  
Agree that it would be better to highlight the entire  
item, e.g., repaint "English" in reverse video when it  
is selected.  That's what the EFI Boot Manager, elilo,  
and the SLES installer do.  
  




Version-Release number of selected component (if applicable):
RH4 U3

How reproducible:
This is easily reproduced when installing using the text mode installer.  Even 
on the first screen where language is to be specified, there is no easy way to 
tell whether I've selected zimbabwe or french.  This continues on almost every 
screen throughout the install.

Steps to Reproduce:
1.  Boot installer and use the console or text mode
2.  I recommend trying the windows cmd window as it is not functional
3.  Tab around and hit space bar in the first window.
  
Actual results:
no highlited selections

Expected results:
highlighted selections

Additional info:
Comment 3 Jiri Pallich 2012-06-20 11:52:46 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.