Bug 1859518 - Create VM Wizard Edit Disk Modal does not respect cloned PVC namespace
Summary: Create VM Wizard Edit Disk Modal does not respect cloned PVC namespace
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Filip Krepinsky
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-22 10:16 UTC by Yaacov Zamir
Modified: 2020-10-27 16:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Consequence: it was not possible to edit datavolume disks from a different namespace than the VM properly in disk modal Fix: Disk modal properly registers the right namespace of datavolume disks
Clone Of:
Environment:
Last Closed: 2020-10-27 16:16:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
the error message in the disk edit (112.14 KB, image/png)
2020-07-22 10:16 UTC, Yaacov Zamir
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6111 0 None closed Bug 1859518: kubevirt: fix editing of pvc datavolumes from different namespaces 2020-09-02 02:08:46 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:17:00 UTC

Description Yaacov Zamir 2020-07-22 10:16:25 UTC
Created attachment 1702049 [details]
the error message in the disk edit

Description of problem:
In Create VM Wizard, when editing a cloned PVC disk with namespace that is different then the VM namespace, the edit VM modal will load the VM namespace instead of the PVC namespace.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Open Create VM wizard
2. Go to Storage Tab
3. Attach Cloned Disk from a different namespace, and save it
4. Open the Disk Edit modal.

Actual results:
the namespace is wrong and we get an error: Selected <pvc name> is not available


Expected results:
name and namespace of PVC is currect


Additional info:

Comment 3 Guohua Ouyang 2020-09-02 03:22:59 UTC
verified on master.

Comment 5 errata-xmlrpc 2020-10-27 16:16:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.