Bug 185969 - scriplets are incorrect
scriplets are incorrect
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-20 11:06 EST by Bill Nottingham
Modified: 2014-03-16 22:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-30 06:03:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-03-20 11:06:16 EST
Version-Release number of selected component (if applicable):

9.3.2-8 (probably applies to FC4 version as well)

1) useradd/groupadd are not unconditional
2) useradd/groupadd has code to be called without specifying a user (FC4 version
as well)
3) chkconfig --add is not unconditional (this is broken in prior versions too)
4) %pre calls logger and echo
5) 
        [ -d /selinux ] && [ -x /sbin/restorecon ] && /sbin/restorecon
/etc/rndc.conf /etc/named.conf >/dev/null 2>&1 ;

This isn't 100% right; /selinux will exist even if selinux isn't in use.
However, it won't do anything *wrong* in the non-selinux case.
But, this calls restorecon without prereqing it. If this is expected
to work on initial install, it's not guaranteed, because of ordering.

6) removing user/group on removal isn't necessary
7) triggerpostun could be cleaned up using the --resetpriorities flag of
chkconfig, added in 1.3.26-1.

8) bind-config %post calls chcon without prereqing it
9) bind-sdp %post calls:
mktemp
grep
<various coreutils things>
sed
restorecon

all without prereqs.
Comment 1 Jason Vas Dias 2006-03-20 16:43:28 EST
fixed with bind-9.3.2-10.FC5
Comment 2 Bill Nottingham 2006-03-20 22:27:45 EST
-sdp and -config still call chcon/restorecon without a prereq; while it will
probably be installed correctly via bind's dep, it's best to have it listed.
Comment 3 Mattias Ellert 2006-04-20 15:20:38 EDT
For me yum update on a freshly installed FC5 gave:

  Updating  : bind-chroot                  ##################### [195/574]
/var/tmp/rpm-tmp.72076: line 2: /usr/sbin/bind-chroot-admin: No such file or
directory
error: %post(bind-chroot-9.3.2-16.FC5.i386) scriptlet failed, exit status 1

After running the update I have:

[ellert@localhost ~]$ rpm -qa | grep ^bind | sort
bind-9.3.2-16.FC5
bind-chroot-9.3.2-16.FC5
bind-chroot-9.3.2-4.1
bind-config-9.3.2-16.FC5
bind-libs-9.3.2-16.FC5
bind-utils-9.3.2-16.FC5

i.e. two versions of bind-chroot.

Comment 4 Jason Vas Dias 2006-04-20 16:45:16 EDT
(In reply to comment #3)
> For me yum update on a freshly installed FC5 gave:
> 
>   Updating  : bind-chroot                  ##################### [195/574]
> /var/tmp/rpm-tmp.72076: line 2: /usr/sbin/bind-chroot-admin: No such file or
> directory
> error: %post(bind-chroot-9.3.2-16.FC5.i386) scriptlet failed, exit status 1
> 
 
This shows that your bind-9.2.2-16.FC5 update did not complete - 
the bind- main package provides /usr/sbin/bind-chroot-admin ;
if the bind update had completed, you would have had no problems.
It sounds like you may have aborted a yum session before it was
complete, and your RPMs are in an inconsistent state.

You can easily fix this:
# wget
ftp://download.fedora.redhat.com/pub/fedora/linux/core/updates/5/i386/'bind-*9.3.2-16*'
# rpm -Uvh --force bind-*.rpm

I've tested upgrading via yum from the bind-9.3.2-4.1 RPMs to bind-9.3.2-16+
and had no such problems .
Comment 5 Adam Tkac 2007-05-30 06:03:22 EDT
Looks like fixed. If still exists, please reopen.

Regards, Adam

Note You need to log in before you can comment on or make changes to this bug.