Bug 1859834 - White screen when cancel Pipeline Create with open sidebar
Summary: White screen when cancel Pipeline Create with open sidebar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.z
Assignee: Christoph Jerolimov
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1856268
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-23 06:38 UTC by Christoph Jerolimov
Modified: 2020-08-04 14:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-04 14:16:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6083 0 None closed [release-4.4] Bug 1859834: Fix crash (white screen) when cancel Pipeline Create with open sidebar 2020-07-31 18:00:28 UTC
Red Hat Product Errata RHBA-2020:3128 0 None None None 2020-08-04 14:16:24 UTC

Description Christoph Jerolimov 2020-07-23 06:38:49 UTC
+++ This bug was initially created as a clone of Bug #1856268 +++

Description of problem:
When creating a pipeline, open a sidebar and press cancel the Console "crashes" and shows just a white screen.

Version-Release number of selected component (if applicable):
4.6.0-0.ci-2020-07-06-063139

How reproducible:
Always

Steps to Reproduce:
1. Install OpenShift Pipelines operator (tested with 1.0.1)
2. Open the Developer perspective and select Pipeline from the navigation.
3. Select "Create Pipeline"
4. Select task "git-clone" from the task list
5. Click on task "git-clone" to open the config sidebar on the right side
6. Press cancel (on the bottom left) while the sidebar is open!

Actual results:
White screen with the following message in the browser log:

Uncaught TypeError: Cannot read property 'name' of undefined
    at TaskSidebar (:9000/static/pipeline-builder-page-909c555cb842a4083ed6.js:774)
    at renderWithHooks (vendors~main-da01bf789e9762cb7930.js:261216)
    at updateFunctionComponent (vendors~main-da01bf789e9762cb7930.js:263033)


Expected results:
That we route is switched back to the Pipeline list.

Additional info:

Comment 1 Christoph Jerolimov 2020-07-23 10:06:12 UTC
The Dev Console page to create a custom Pipeline without a yaml was introduced in 4.5. So we can not fix or backport https://bugzilla.redhat.com/show_bug.cgi?id=1856268 to 4.4.

Closed.

Comment 2 Christoph Jerolimov 2020-07-23 11:56:53 UTC
The Pipeline Builder exists in 4.4 and has the same crash we fixed in 4.5. So reopen this ticket and create a PR for it.

Comment 5 Abhishek K N 2020-07-26 15:45:57 UTC
Validated the scenario on following 4.4 build & able to navigate back to pipeline list on cancelling new request with sidebar open. No exception or white screen observed.

OpenShift Version: 4.4.0-0.ci-2020-07-25-152215
Kubernetes Version: v1.17.1

Comment 7 errata-xmlrpc 2020-08-04 14:16:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.15 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3128


Note You need to log in before you can comment on or make changes to this bug.