Bug 1860054 (CVE-2020-14338) - CVE-2020-14338 wildfly: XML validation manipulation due to incomplete application of use-grammar-pool-only in xercesImpl
Summary: CVE-2020-14338 wildfly: XML validation manipulation due to incomplete applica...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2020-14338
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
: 1860076 (view as bug list)
Depends On:
Blocks: 1860056
TreeView+ depends on / blocked
 
Reported: 2020-07-23 15:57 UTC by Chess Hazlett
Modified: 2021-08-11 18:26 UTC (History)
76 users (show)

Fixed In Version: xerces jboss-2.12.0.SP3
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in Wildfly's implementation of Xerces, specifically in the way the XMLSchemaValidator class in the JAXP component of Wildfly enforced the "use-grammar-pool-only" feature. This flaw allows a specially-crafted XML file to manipulate the validation process in certain cases. This issue is the same flaw as CVE-2020-14621, which affected OpenJDK, and uses a similar code.
Clone Of:
Environment:
Last Closed: 2020-10-13 20:21:20 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2020:4244 0 None None None 2020-10-13 16:48:13 UTC
Red Hat Product Errata RHSA-2020:4245 0 None None None 2020-10-13 16:52:22 UTC
Red Hat Product Errata RHSA-2020:4246 0 None None None 2020-10-13 16:56:53 UTC
Red Hat Product Errata RHSA-2020:4247 0 None None None 2020-10-13 17:01:45 UTC
Red Hat Product Errata RHSA-2020:4931 0 None None None 2020-11-04 19:24:35 UTC
Red Hat Product Errata RHSA-2020:5361 0 None None None 2020-12-16 07:20:35 UTC
Red Hat Product Errata RHSA-2021:0600 0 None None None 2021-02-17 12:08:19 UTC
Red Hat Product Errata RHSA-2021:0603 0 None None None 2021-02-17 13:40:16 UTC
Red Hat Product Errata RHSA-2021:3140 0 None None None 2021-08-11 18:26:04 UTC

Description Chess Hazlett 2020-07-23 15:57:34 UTC
A flaw was found in Wildfly's implementation of xerces, specifically in the way the XMLSchemaValidator class in the JAXP component of Wildfly enforced the "use-grammar-pool-only" feature.  A specially-crafted XML file could possibly use this flaw to manipulate with the validation process in certain cases. This is the same flaw as CVE-2020-14621, which affected OpenJDK, which uses similar code.

Comment 3 Guilherme de Almeida Suckevicz 2020-07-23 17:48:21 UTC
*** Bug 1860076 has been marked as a duplicate of this bug. ***

Comment 6 Ted Jongseok Won 2020-07-24 03:01:36 UTC
This vulnerability is out of security support scope for the following products:
 * Red Hat JBoss Enterprise Application Platform 5
 * Red Hat JBoss Enterprise Application Platform 6
 * Red Hat JBoss Data Grid 7
 * Red Hat JBoss Fuse 6
 * Red Hat JBoss AMQ 6
 * Red Hat JBoss BRMS 6
 * Red Hat JBoss Data Virtualization 6
 * Red Hat JBoss Operations Network 3
 * Red Hat JBoss Fuse Service Works 6
 * Red Hat JBoss SOA Platform 5

Please refer to https://access.redhat.com/support/policy/updates/jboss_notes for more details.

Comment 16 errata-xmlrpc 2020-10-13 16:48:09 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 6

Via RHSA-2020:4244 https://access.redhat.com/errata/RHSA-2020:4244

Comment 17 errata-xmlrpc 2020-10-13 16:52:18 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 8

Via RHSA-2020:4245 https://access.redhat.com/errata/RHSA-2020:4245

Comment 18 errata-xmlrpc 2020-10-13 16:56:48 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 7

Via RHSA-2020:4246 https://access.redhat.com/errata/RHSA-2020:4246

Comment 19 errata-xmlrpc 2020-10-13 17:01:41 UTC
This issue has been addressed in the following products:

  EAP 7.3.3

Via RHSA-2020:4247 https://access.redhat.com/errata/RHSA-2020:4247

Comment 20 Product Security DevOps Team 2020-10-13 20:21:20 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2020-14338

Comment 21 errata-xmlrpc 2020-11-04 19:24:31 UTC
This issue has been addressed in the following products:

  Red Hat Single Sign-On 7.4.3

Via RHSA-2020:4931 https://access.redhat.com/errata/RHSA-2020:4931

Comment 22 errata-xmlrpc 2020-12-16 07:20:32 UTC
This issue has been addressed in the following products:

  Red Hat Openshift Application Runtimes

Via RHSA-2020:5361 https://access.redhat.com/errata/RHSA-2020:5361

Comment 23 errata-xmlrpc 2021-02-17 12:08:13 UTC
This issue has been addressed in the following products:

  RHPAM 7.10.0

Via RHSA-2021:0600 https://access.redhat.com/errata/RHSA-2021:0600

Comment 24 errata-xmlrpc 2021-02-17 13:40:13 UTC
This issue has been addressed in the following products:

  RHDM 7.10.0

Via RHSA-2021:0603 https://access.redhat.com/errata/RHSA-2021:0603

Comment 25 errata-xmlrpc 2021-08-11 18:26:00 UTC
This issue has been addressed in the following products:

  Red Hat Fuse 7.9

Via RHSA-2021:3140 https://access.redhat.com/errata/RHSA-2021:3140


Note You need to log in before you can comment on or make changes to this bug.