Bug 1860276 - `oc debug` command can't work
Summary: `oc debug` command can't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.6.0
Assignee: Mike Dame
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-24 07:51 UTC by zhou ying
Modified: 2020-10-27 16:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:16:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 502 0 None closed debug: fix dry-run flag parsing 2021-01-25 12:53:25 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:17:14 UTC

Description zhou ying 2020-07-24 07:51:40 UTC
Description of problem:
`oc debug` command can't work

Version-Release number of selected component (if applicable):
[root@dhcp-140-138 ~]# oc version 
Client Version: 4.6.0-202007221854.p0-5f270d5

How reproducible:
Always

Steps to Reproduce:
1. `oc debug node/ip-xxxx.internal` 
2. `oc debug pod/podname`

Actual results:
1-2. the command exit without create debug pod.

Expected results:
1. Should create debug pod . 

Additional info:
Client Version: 4.6.0-202005061824-29e9a33 works well

Comment 3 Mike Dame 2020-07-27 15:46:29 UTC
It looks like this will be fixed in the next available oc nightly build by the changes in https://github.com/openshift/oc/pull/502, so moving this to modified

Comment 8 zhou ying 2020-07-29 02:28:38 UTC
Confirmed with latest oc client, the issue has fixed:
[root@dhcp-140-138 ~]# oc version --client
Client Version: 4.6.0-202007282157.p0-49e8811


[root@dhcp-140-138 ~]# oc debug node/ip-xxxx.compute.internal
Starting pod/ip-xxxx-debug ...
To use host binaries, run `chroot /host`
Pod IP: 10.0.151.144
If you don't see a command prompt, try pressing enter.
sh-4.2# chroot /host
sh-4.4# exit
exit
sh-4.2# exit
exit

Removing debug pod ...

Comment 10 errata-xmlrpc 2020-10-27 16:16:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.