Bug 18605 - Non FHS [or Red Hat] compliance in various Application Library packages
Summary: Non FHS [or Red Hat] compliance in various Application Library packages
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: acroread   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-07 14:39 UTC by Mike MacCana
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-16 17:05:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike MacCana 2000-10-07 14:39:55 UTC
The /opr directory is depreciated and not a partof the Linux File Heirarchy
system. Furthermore it is no longer is use by Red Hat, or part of the
filesystem tree package.

/opt is an abbreviation of the word optional', applicable for non OS [or OS
vendor] applications in UNIX. The directory is inappropriate for Linux, as
all [or most] software is `optiona' [non-OS vendor supplied].

The FHS system specifies that end user applications [such as StarOffice
5.2] sort their files based on function [binary, documentation, etc] and
install throughout the appropriate branches of /usr [/usr/bin/soffice,
etc].

In the event the application absolutely requires its own directory tree,
/usr/local/<application> is also appropriate. Either way /opt/* is not.

I have marked this issue as medium severity due to Red Hat's recent moves
to align its Linux distribution with the File Heirarchy System, and this
bugs detrimental effect on those moves.

Comment 1 Ngo Than 2000-11-16 15:02:05 UTC
i don't see any problem with FHS  here.


Note You need to log in before you can comment on or make changes to this bug.