Bug 186055 - Mirror list is incomplete
Mirror list is incomplete
Status: CLOSED RAWHIDE
Product: Fedora Infrastructure
Classification: Retired
Component: website (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg DeKoenigsberg
Elliot Lee
http://fedora.redhat.com/download/mir...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 07:38 EST by Jochen Wiedmann
Modified: 2007-04-18 13:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 12:29:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Perl script for creating a preliminary mirror list. (628 bytes, text/plain)
2006-03-21 07:38 EST, Jochen Wiedmann
no flags Details

  None (edit)
Description Jochen Wiedmann 2006-03-21 07:38:49 EST
The list of the Fedora mirrors, which is used by yum is incomplete.
Unfortunately, this breaks yum in some cases, because yum takes the only mirror
and attempts to perform a "REST" command, which isn't supported by the Fedora
download server. Due to lack of other mirrors, yum stops working.

Attached you find a simple script for generating a preliminary list. It reads
the official mirror list and adds the required subdirectories.
Comment 1 Jochen Wiedmann 2006-03-21 07:38:49 EST
Created attachment 126390 [details]
Perl script for creating a preliminary mirror list.
Comment 2 Elliot Lee 2006-03-21 12:29:48 EST
'download.fedoraproject.org', which should be the sole host listed in the mirror
list, should redirect you to a random mirror. There were some hiccups where the
list of Fedora mirrors used by yum listed 'download.fedora.redhat.com' instead
of download.fedoraproject.org, but this should be fixed within an hour.
Comment 3 Mary Ellen Foster 2006-03-22 07:43:31 EST
At the moment (2006-03-22 13:47 GMT+1)
    wget http://fedora.redhat.com/download/mirrors/fedora-core-5
returns a file that consists of 34 copies of the same line:
    http://download.fedoraproject.org/pub/fedora/linux/core/5/$ARCH/os/

I suspect that should actually be returning 34 *different* mirrors? OR does yum
do something other than what wget does? My "yum update" seems to be pulling
exclusively from download.fedoraproject.org and is *VERY* *VERY* slow.
Comment 4 Elliot Lee 2006-03-22 10:10:47 EST
download.fedoraproject.org redirects to a random mirror.

It will be slow because tons of people are downloading FC5. Can't help that part :)

Note You need to log in before you can comment on or make changes to this bug.