Bug 186059 - ide drive not recognized (dmraid problem)
ide drive not recognized (dmraid problem)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 08:25 EST by Gene Czarcinski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-23 14:05:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci (1.56 KB, text/plain)
2006-03-21 08:26 EST, Gene Czarcinski
no flags Details
lspci -v (6.77 KB, text/plain)
2006-03-21 08:27 EST, Gene Czarcinski
no flags Details
186059giorio.lspci (3.18 KB, text/plain)
2006-03-21 12:27 EST, enrico giorio
no flags Details

  None (edit)
Description Gene Czarcinski 2006-03-21 08:25:07 EST
Description of problem:

There is a problem running the FC5 installer (anaconda) on some hardware.  This
may be related to https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179100

This also was mentioned on the fedora-test list by Dave Cantrell.

The problem is that the regular pata drives are not recognized properly and
anaconda things the the first drive (hda) is a raid device (the drives have
never been used in a raid configuration and FC4 is installed on them also). 
Booting the install with "nodmraid" fixes the problem.

I first had the problem with FC5test2 but was not able to do much testing this
cycle.  I was surprised to see the problem still exists in the final (GOLD)
release and that no mention is made of using "nodmraid" in the RELEASE-NOTES.

The hardware is an ABIT AN8 SLI motherboard (Athlon64 x2 4400 processor). 
Attached are lspci and lspci -v outputs.


Version-Release number of selected component (if applicable):
FC5 i386 and x86_64 tested

How reproducible:
yes
Comment 1 Gene Czarcinski 2006-03-21 08:26:42 EST
Created attachment 126391 [details]
lspci
Comment 2 Gene Czarcinski 2006-03-21 08:27:26 EST
Created attachment 126392 [details]
lspci -v
Comment 3 enrico giorio 2006-03-21 12:27:57 EST
Created attachment 126408 [details]
186059giorio.lspci

I have experienced the same anaconda problem, the entry nodmraid have not 
fixed the problem yet. Attached lspci -v.
Comment 4 Gene Czarcinski 2006-03-21 15:04:20 EST
Oops ... got my systems confused.  The system with the problem has a ASUS A8N-E
motherboard with a X2 4400+.
Comment 5 Peter Jones 2006-03-22 10:58:15 EST
Can you run "dmraid -ay -t" and show us the output?
Comment 6 Gene Czarcinski 2006-03-22 11:48:42 EST
Output of dmrain -ay -t is:

pdc_bjahffii: 0 240121665 linear /dev/hda 0

hda is a Maxtor 6Y120P0 with:

Disk /dev/hda: 122.9 GB, 122942324736 bytes
255 heads, 63 sectors/track, 14946 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

from fdisk -l
Comment 7 Peter Jones 2006-03-22 12:46:39 EST
OK, so at some point this disk (and one other disk) was plugged into a Promise
software raid controller, and a raid volume was created.

If you do: 

dmraid -E -f pdc /dev/hda

and then restart the installer, does it work?

(and are you *sure* booting with "nodmraid" didn't fix it?  That option causes
it not to even try to detect this, and that should work)
Comment 8 Gene Czarcinski 2006-03-22 13:11:58 EST
1. Using "nodmraid" with the installer worked fine for me ... another commentor:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=186059#c3 said nodmrain did
not work for him.

2. will running dmraid -E -f pdc /dev/hda destroy the current partitions (I have
other OS installed on this system).

3. I have had a pair of Maxtor 120GB drives for some time and have never used
wither software or hardware raid.  At one point, one of this drives may (MAY)
have been plugged into a promise controller but I certainly did not configure it
for raid (at least as far as I know).  FC4 did not have the "dmraid" problem
when it was installed on this system (and still is installed).

4. Although this system is a "test" system which I can blow away at any time, it
will take some time to do the test if the partitions are destroyed.  If
partitions are not destroyed, I should be able to do the test in a day or so.
Comment 9 Peter Jones 2006-03-22 14:59:35 EST
<i>2. will running dmraid -E -f pdc /dev/hda destroy the current partitions (I
have other OS installed on this system).</i>

Well, it will wipe the metadata from the PDC raid controller.  It's hard to say
how safe that is.  Since we can identify it, that *probably* means it's in an
unallocated block of some filesystem, and thus safe.  But there's not a very
good way to be sure.  It should leave the *partition table* intact; typically
the raid metadata is near the end of the disk.

FC4 doesn't support dmraid at all, so it's no surprise that it doesn't have any
problem.
Comment 10 Gene Czarcinski 2006-03-22 18:16:02 EST
Ok, I gave it a try but I don't believe it worked:

[root@raven ~]# dmraid -E -f pdc /dev/hda
ERROR: option missing/invalid option combination with -f

I assume it did not work so I did not try reinstalling.
Comment 11 Boris 2006-03-23 14:40:58 EST
I used dmraid -E -r
It's safe for the partition table, and fixes the problem.
Comment 12 Gene Czarcinski 2006-04-23 14:05:12 EDT
closing ... I "finally" got around to fixing things ... "dmraid -E -r" work
whereas "dmraid -E -f" does not work.

I am not sure how pdc was ever set but it has been erased now.

Note You need to log in before you can comment on or make changes to this bug.