Bug 186060 - static version of libjpeg was dropped
static version of libjpeg was dropped
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libjpeg (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Tom Lane
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 08:35 EST by Matthias Hensler
Modified: 2013-07-02 23:09 EDT (History)
4 users (show)

See Also:
Fixed In Version: 6b-38.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 11:23:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Hensler 2006-03-21 08:35:30 EST
Description of problem:

With FC5 the static part of libjpeg was dropped. Since it is needed to create
static binaries for bootsplash utilities I would like to either have libjpeg.a
in libjpeg-devel (as it was with FC4 and earlier) or a seperate libjpeg-static
package.

Regards.
Comment 1 Sergey V. Udaltsov 2006-03-31 20:47:25 EST
Actually any building involving -ljpeg (for example, using libsvg.pc) is broken
without this library.
Comment 2 Eric Moret 2006-10-17 20:19:41 EDT
Ping, can we get the static library back... I also need it to build a bootsplash
utility like Matthias outlined above.
Comment 3 Tom Lane 2006-10-17 23:54:59 EDT
Hmm ... but the general evolution of Fedora has been away from static linking.  Shouldn't this bug be filed 
against whatever part of the boot infrastructure can't handle libjpeg.so?

I don't have a problem with providing libjpeg.a, but I am kinda wondering how it is that image 
decompression would be lower down the food chain than shlib support.  Seems like there's something 
wrong with this picture...
Comment 4 Eric Moret 2006-10-18 00:21:08 EDT
I am not sure why the static libs are required. Just as an FYI, the bootsplash 
I am trying to compile is splashy 
http://splashy.alioth.debian.org/wiki/doku.php and here is a message describing 
the things needed to be done to compile on FC5:
http://lists.alioth.debian.org/pipermail/splashy-users/2006-July/000170.html

Note the following:
- install DirectFB from a tarball and built to generate static libs
- add a static libjpeg from libjpeg-static-6b-36.2.1.cubbi1.i386.rpm
- grabbed the srpm for procps ( procps-3.2.6-3.5.src.rpm ), and edited the spec 
file to use SHARED=0, therefore creating libproc.a
- manually getting the proc header files from the procps srpms package

Now, it may just be that I have not spent enough time trying to build splashy 
with dynamic libs.
Comment 5 Christophe GRENIER 2006-11-05 15:57:24 EST
I can't produce Linux static binary of PhotoRec (package testdisk in FC Extras)
for non Fedora users since static libjpeg is missing. I would like to either
have libjpeg.a in libjpeg-devel (as it was with FC4 and earlier) or a seperate
libjpeg-static package.

Comment 6 Tom Lane 2007-06-25 23:40:58 EDT
libjpeg-static package created as of libjpeg-6b-38.  Pushed to F7 testing today, will backpatch as 
opportunity presents.
Comment 7 Fedora Update System 2007-06-26 23:51:23 EDT
libjpeg-6b-38.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2007-07-11 11:23:05 EDT
libjpeg-6b-38.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.