Bug 1860736 - Installed operator for all namespaces display duplicated lines in list view
Summary: Installed operator for all namespaces display duplicated lines in list view
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-27 02:52 UTC by XiaochuanWang
Modified: 2020-10-27 16:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:17:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
bug screenshot (183.75 KB, image/png)
2020-07-27 02:52 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6109 0 None open Bug 1860736: Remove duplicate lines from Installed Operators list page 2020-07-27 08:28:36 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:20:24 UTC

Description XiaochuanWang 2020-07-27 02:52:06 UTC
Created attachment 1702467 [details]
bug screenshot

Description of problem:
Install an operator for All-namespace, the Installed operator list display duplicated lines for this operator.

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-07-25-091217

How reproducible:
Always

Steps to Reproduce:
1. Install an operator for All-namespace such as "Portworx Enterprise"
2. Check Installed Operator list view
3.

Actual results:
Display duplicated lines for Portworx Enterprise

Expected results:
Should only display one line

Additional info:
Refer to the screenshot

Comment 3 Yanping Zhang 2020-07-30 10:06:38 UTC
Checked on OCP 4.6 cluster with payload 4.6.0-0.nightly-2020-07-29-214846
Install "OpenShift Serverless Operator" to all namespace, checked on installed operators page, there is only one line show the installed serverless operator.
The bug is fixed.

Comment 5 errata-xmlrpc 2020-10-27 16:17:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196

Comment 6 errata-xmlrpc 2020-10-27 16:20:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.