Bug 1860768 - URL for Knative Service shouldn't use tag of first traffic distribution
Summary: URL for Knative Service shouldn't use tag of first traffic distribution
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.6.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1861358
TreeView+ depends on / blocked
 
Reported: 2020-07-27 05:32 UTC by Jaivardhan Kumar
Modified: 2020-10-27 16:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Route Decorator on knativeService was redirecting to route with Revision in case of traffic split Consequence: User will be redirected to a revision specific route instead of a base service route Fix: Updated route decorator to point to ksvc base route always Result:
Clone Of:
: 1861358 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:17:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6095 0 None closed Bug 1860768: fixes issue with ksvc decorator not showing base route 2020-10-15 14:16:17 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:20:24 UTC

Description Jaivardhan Kumar 2020-07-27 05:32:39 UTC
Description of problem: On OpenShift 4.5 deploying a Knative Service with traffic distribution will show an invalid URL for general service address in DevConsole. The URL should be the same as advised by Knative Service, but now it's the same as one of the revisions of traffic distribution.


Version-Release number of selected component (if applicable): Serverless 1.7.1


How reproducible: Always


Steps to Reproduce:
1. Create namespace demo
2. Deploy a knative service in namespace demo with image: quay.io/cardil/knative-serving-showcase
3. Edit knative service and change container image to: docker.io/openshift/hello-openshift
4. Set traffic distribution to be 50% of one revision and 50% of other
5. Check the URL of main URL button in DevConsole

Actual results:
URL is pointing to one of the revisions

Expected results: URL should be pointing to general way, without actual revision in it, enabling usage of traffic spliting


Additional info:

Comment 5 Karthik Jeeyar 2020-07-30 11:50:01 UTC
Verified on 
URL : https://console-openshift-console.apps.dev-svc-4.6-073007.devcluster.openshift.com/topology/ns/rhd-test/graph?selectId=61ed5391-6f8e-4c83-a949-ca68bf36e434
Build NO: 4.6.0-0.nightly-2020-07-25-091217
User: Kubeadmin

Comment 6 Karthik Jeeyar 2020-07-30 11:50:11 UTC
Verified on 
URL : https://console-openshift-console.apps.dev-svc-4.6-073007.devcluster.openshift.com/topology/ns/rhd-test/graph?selectId=61ed5391-6f8e-4c83-a949-ca68bf36e434
Build NO: 4.6.0-0.nightly-2020-07-25-091217
User: Kubeadmin

Comment 8 errata-xmlrpc 2020-10-27 16:17:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196

Comment 9 errata-xmlrpc 2020-10-27 16:20:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.