This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 186080 - urlgrabber errors on usage
urlgrabber errors on usage
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-urlgrabber (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 10:20 EST by adam williams
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 06:55:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam williams 2006-03-21 10:20:39 EST
Description of problem:

using urlgrabber to get anything generates an error.  

Version-Release number of selected component (if applicable):

Fedora Core 5 with python-urlgrabber-2.9.8-2

How reproducible:

every usage

Steps to Reproduce:
1. urlgrabber
http://download.fedora.redhat.com/pub/fedora/linux/core/5/i386/os/repodata/repomd.xml
  
Actual results:

urlgrabber
http://download.fedora.redhat.com/pub/fedora/linux/core/5/i386/os/repodata/repomd.xml
Traceback (most recent call last):
  File "/usr/bin/urlgrabber", line 124, in ?
    main()
  File "/usr/bin/urlgrabber", line 120, in main
    filename = urlgrab(url,filename=file,**kwargs)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 573, in
urlgrab
    return default_grabber.urlgrab(url, filename, **kwargs)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 784, in
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 702, in _retry
    r = apply(func, (opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 770, in
retryfunc
    fo = URLGrabberFileObject(url, filename, opts)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 893, in
__init__
    self._do_open()
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 960, in
_do_open
    fo, hdr = self._make_request(req, opener)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 1075, in
_make_request
    raise URLGrabError(4, _('IOError: %s') % (e, ))
urlgrabber.grabber.URLGrabError: [Errno 4] IOError: <urlopen error (2, 'No such
file or directory')>


Expected results:

to properly get the file

Additional info:

i've tried FC4's python-urlgrabber rpm version python-urlgrabber-2.9.6-1 and get
the same error, so I'm not sure where the problem lies.
python-urlgrabber-2.9.6-1 worked fine on my computer when it was FC4 (I upgraded
to FC yesterday).  because of this problem, yum and pup do not work on my
computer, and I need them to work for fedora updates.
Comment 1 Wesley Haines 2006-03-21 17:38:22 EST
I'm receiving this same problem as well. Here's what yum says: 

[root@Kremit yum]# yum update --disablerepo=livna
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                                                                 [1/7]
Cannot find a valid baseurl for repo: core
Error: Cannot find a valid baseurl for repo: core

...and with livna enabled: 

[root@Kremit yum]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna                                                                [1/8]
http://rpm.livna.org/fedora/5/i386/repodata/repomd.xml: [Errno 4] IOError: <urlo
pen error (2, 'No such file or directory')>
Trying other mirror.
http://livna.cat.pdx.edu/fedora/5/i386/repodata/repomd.xml: [Errno 4] IOError: <
urlopen error (11, 'Resource temporarily unavailable')>
Trying other mirror.
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/5/i386/repodata/repomd.xml: [E
rrno 4] IOError: <urlopen error (11, 'Resource temporarily unavailable')>
Trying other mirror.
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/5/i386/repodat
a/repomd.xml: [Errno 4] IOError: <urlopen error (11, 'Resource temporarily unava
ilable')>
Trying other mirror.
Cannot open/read repomd.xml file for repository: livna
failure: repodata/repomd.xml from livna: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from livna: [Errno 256] No more mirrors to t ry.
--------

I've removed yum and python-urlgrabber, then re-installed them, and the same
error occurs. urlgrabber appears to be in its proper place: 

[root@Kremit yum]# ll /usr/lib/python2.4/site-packages/urlgrabber/
total 388
-rw-r--r-- 1 root root 16837 Oct 22 17:57 byterange.py
-rw-r--r-- 1 root root 15122 Mar 14 15:58 byterange.pyc
-rw-r--r-- 1 root root 14983 Mar 14 15:58 byterange.pyo
-rw-r--r-- 1 root root 52875 Mar 14 15:58 grabber.py
-rw-r--r-- 1 root root 47038 Mar 14 15:58 grabber.pyc
-rw-r--r-- 1 root root 47038 Mar 14 15:58 grabber.pyo
-rw-r--r-- 1 root root  2259 Feb 22 13:27 __init__.py
-rw-r--r-- 1 root root  1706 Mar 14 15:58 __init__.pyc
-rw-r--r-- 1 root root  1706 Mar 14 15:58 __init__.pyo
-rw-r--r-- 1 root root 20230 Oct 22 17:57 keepalive.py
-rw-r--r-- 1 root root 17814 Mar 14 15:58 keepalive.pyc
-rw-r--r-- 1 root root 17814 Mar 14 15:58 keepalive.pyo
-rw-r--r-- 1 root root 18069 Feb 22 13:26 mirror.py
-rw-r--r-- 1 root root 16236 Mar 14 15:58 mirror.pyc
-rw-r--r-- 1 root root 16236 Mar 14 15:58 mirror.pyo
-rw-r--r-- 1 root root 18235 Aug 19  2005 progress.py
-rw-r--r-- 1 root root 17015 Mar 14 15:58 progress.pyc
-rw-r--r-- 1 root root 17015 Mar 14 15:58 progress.pyo

My internet connection works fine, and the URLs that yum spits out work fine in
a web browser.
Comment 2 Wesley Haines 2006-03-22 02:46:12 EST
Sorry for the extra e-mails, but I've found a solution to this problem and
posted it here: 
http://fedoraforum.org/forum/showthread.php?p=478057#post478057

Please let me know if this fixes your issue.

Basically, /etc/nsswitch.conf had an incorrect "hosts:" line, and copying over
the default configuration (nsswitch.conf.rpmnew) took care of the problem. I
believe that this was caused by a previous install of a package called
mDNSresponder, required for the Gizmo Project (VoIP software). That install
changed the hosts line to: 

hosts: files mdns nisplus dns

Now for the speculation: After I upgraded to FC5, Avahi started conflicting with
mDNSresponder (or mDNS just stopped working) and the "mdns" entry started
causing all kinds of problems with yum, wget, etc. Oh well... I guess that's
what I get for installing non-Fedora RPM packages, but it would have been nice
to configure Avahi or otherwise have the installer check for something like this.
Comment 3 adam williams 2006-03-22 06:55:48 EST
Wesley, copying /etc/nsswitch.conf.rpmnew over /etc/nsswitch.conf solved my
problem.  yum now works fine for me, thanks for the assistance.

Note You need to log in before you can comment on or make changes to this bug.