Bug 1860830 - After upgrading to 4.3.28 customer observed mistmatch between node labels (region=CanadaCentral) and pv affinity (region=canadacentral)
Summary: After upgrading to 4.3.28 customer observed mistmatch between node labels (re...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.z
Assignee: Alberto
QA Contact: sunzhaohua
URL:
Whiteboard:
: 1858328 (view as bug list)
Depends On: 1860829
Blocks: 1860832
TreeView+ depends on / blocked
 
Reported: 2020-07-27 08:19 UTC by Alberto
Modified: 2020-09-18 08:12 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1860829
: 1860832 (view as bug list)
Environment:
Last Closed: 2020-08-18 11:45:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25326 0 None closed Bug 1860830: Ensure Azure availability zone is always in lower cases 2021-01-18 07:42:04 UTC
Red Hat Product Errata RHBA-2020:3334 0 None None None 2020-08-18 11:46:11 UTC

Comment 2 Alberto 2020-07-29 15:28:38 UTC
*** Bug 1858328 has been marked as a duplicate of this bug. ***

Comment 6 sunzhaohua 2020-08-10 03:17:57 UTC
Verified
clusterversion: 4.4.0-0.nightly-2020-08-08-143753
steps:
1. Create a cluster in Azure Canada Central. 
2. Check "oc get configmap cloud-provider-config -n openshift-config"  `UseInstanceMetadata=True` is set. 
3. Create PVC using dynamic storage class.
$ oc get pvc
NAME   STATUS   VOLUME                                     CAPACITY   ACCESS MODES   STORAGECLASS      AGE
pvc1   Bound    pvc-9abead4f-10cc-4204-8502-946d29c2e747   1Gi        RWO            managed-premium   66s
$ oc get pv
NAME                                       CAPACITY   ACCESS MODES   RECLAIM POLICY   STATUS   CLAIM          STORAGECLASS      REASON   AGE
pvc-9abead4f-10cc-4204-8502-946d29c2e747   1Gi        RWO            Delete           Bound    default/pvc1   managed-premium            45s
$ oc get po
NAME          READY   STATUS    RESTARTS   AGE
task-pv-pod   1/1     Running   0          61s

Comment 8 errata-xmlrpc 2020-08-18 11:45:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.17 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3334


Note You need to log in before you can comment on or make changes to this bug.