Bug 1860858 - JS error and blank page returned when normal user visit About page
Summary: JS error and blank page returned when normal user visit About page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-27 09:10 UTC by Yadan Pei
Modified: 2020-10-27 16:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:17:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6114 0 None closed Bug 1860858: About modal for regular user shouldn't error out 2020-12-29 01:36:40 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:20:08 UTC

Description Yadan Pei 2020-07-27 09:10:48 UTC
Description of problem:
When normal user visit ? -> About page, got JS error and blank page

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-07-25-091217

How reproducible:
Always

Steps to Reproduce:
1. normal user log in the cluster console
2. visit ? -> About page

Actual results:
2. blank page returned and we can see js error
Uncaught TypeError: m is undefined
    O main-chunk-e1a30816b6037ccf3dd8.min.js:1
    No vendors~main-chunk-4509b154d200312c6f8f.min.js:148377
    Ks vendors~main-chunk-4509b154d200312c6f8f.min.js:148377
    Bs vendors~main-chunk-4509b154d200312c6f8f.min.js:148377
    Fs vendors~main-chunk-4509b154d200312c6f8f.min.js:148377
    Ms vendors~main-chunk-4509b154d200312c6f8f.min.js:148377
    hi vendors~main-chunk-4509b154d200312c6f8f.min.js:148377
    unstable_runWithPriority vendors~main-chunk-4509b154d200312c6f8f.min.js:148671
    li vendors~main-chunk-4509b154d200312c6f8f.min.js:148377
    hi vendors~main-chunk-4509b154d200312c6f8f.min.js:148377
    di vendors~main-chunk-4509b154d200312c6f8f.min.js:148377
    Rs vendors~main-chunk-4509b154d200312c6f8f.min.js:148377
    r vendors~main-chunk-4509b154d200312c6f8f.min.js:148377

Expected results:
2. normal user should be able to view About page

Additional info:

Comment 3 Yanping Zhang 2020-07-30 03:30:20 UTC
Checked on 4.6 cluster with payload 4.6.0-0.nightly-2020-07-29-214846.
Now normal user could access "About" page without js error.
The bug is fixed.

Comment 5 errata-xmlrpc 2020-10-27 16:17:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196

Comment 6 errata-xmlrpc 2020-10-27 16:20:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.