Bug 186100 - Animated mouse pointer wait doesn't work with non-default pointer sizes.
Animated mouse pointer wait doesn't work with non-default pointer sizes.
Status: CLOSED DUPLICATE of bug 180616
Product: Fedora
Classification: Fedora
Component: bluecurve-icon-theme (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 12:22 EST by J.B. Nicholson-Owens
Modified: 2008-04-23 01:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 01:51:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
My xorg.conf file. (2.65 KB, application/octet-stream)
2006-03-24 20:47 EST, J.B. Nicholson-Owens
no flags Details
My Xorg.0.log file. (51.71 KB, text/plain)
2006-03-24 20:49 EST, J.B. Nicholson-Owens
no flags Details
xorg.conf, FC6, nvidia (3.56 KB, application/octet-stream)
2007-05-29 11:46 EDT, E Mair
no flags Details
Xorg.log, FC6, nvidia (24.87 KB, text/plain)
2007-05-29 11:47 EDT, E Mair
no flags Details

  None (edit)
Description J.B. Nicholson-Owens 2006-03-21 12:22:12 EST
Description of problem:
Picking any size of mouse pointer besides the default size means the animation
for wait (the orbiting blue dots) doesn't work.  Instead you get a static image
of the blue dots, no animation.  The style of the pointer you pick doesn't make
any difference, but the size breaks the animation.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Run gnome-mouse-properties.
2. Select a mouse pointer in a different size than the default (the default is
the smallest available size).
3. Do something that will cause the busy mouse pointer like launching a big
program and hovering over that program's window.
4. Watch the lack of animation.

Actual results:
You get a static image -- one frame of the orbiting blue dot animation.

Expected results:
You should get the full animation.

Additional info:
Comment 1 Mike A. Harris 2006-03-24 20:21:32 EST
Thanks for the bug report.  We have reviewed the information you
have provided above, and there is some additional information we
require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X
server log file (/var/log/Xorg.*.log) to the bug report as individual
uncompressed file attachments using the bugzilla file attachment link
below.

We will review this issue again once you've had a chance to attach
this information.

Thanks in advance.
Comment 2 J.B. Nicholson-Owens 2006-03-24 20:47:52 EST
Created attachment 126685 [details]
My xorg.conf file.
Comment 3 J.B. Nicholson-Owens 2006-03-24 20:49:33 EST
Created attachment 126686 [details]
My Xorg.0.log file.

This is the only file /var/log/Xorg.*.log expanded to.
Comment 4 J.B. Nicholson-Owens 2006-03-24 20:51:04 EST
Here are the files you requested.
Comment 5 E Mair 2006-11-06 16:52:27 EST
This still hasn't been fixed in FC6.

Is this filed against the correct component? I don't know how this is supposed
to work, but are large mouse pointer themes simply lacking animated pointers, or
are the default sizes supposed to be enlarged? Maybe this should be filed
against redhat-artwork?
Comment 6 Matěj Cepl 2007-04-04 12:00:01 EDT
I am sorry for the delay. Could you please attach updated FC6 versions of the
above mentioned files as well.

Another things to try is to run X without any /etc/X11/xorg.conf whatsoever
(just to be sure that you have standard configuration) and report the results
(with the log files if appropriate), please?

Thanks a lot and once more I am sorry for the delay.
Comment 7 Adam Jackson 2007-05-26 14:55:07 EDT
I've seen this recently, moving back to assigned.
Comment 8 E Mair 2007-05-29 11:46:26 EDT
Created attachment 155598 [details]
xorg.conf, FC6, nvidia

Attached my xorg.conf and Xorg.0.log files.
I have switched to an NVIDIA card recently, and I'm using the nvidia binary
blob (packaged by Livna), but this bug is still there. Is it really supposed to
be filed against
Comment 9 E Mair 2007-05-29 11:47:23 EDT
Created attachment 155599 [details]
Xorg.log, FC6, nvidia
Comment 10 E Mair 2007-05-29 11:49:41 EDT
(In reply to comment #8)

Oops.

> Is it really supposed to
> be filed against ...

... xorg-x11-drv-ati?
Comment 11 E Mair 2007-06-03 06:12:56 EDT
Still there in F7.
Comment 12 J.B. Nicholson-Owens 2007-06-03 12:18:55 EDT
The animated mouse pointer also fails in a way I might not have noticed before
in Fedora Core 6: I launch a program where I can get the busy pointer
(Thunderbird, switching between emails on a remote and highly overloaded IMAP
server causes the busy pointer) and then I switch from the default (small) mouse
pointer to the biggest mouse pointer.  So now I should see the animated large
mouse pointer (assuming I'll see the animation at all).

Then I do something in TB I'm sure will make the busy pointer appear (pick an
email I have not read before).  I see the small pointer fully animated during
the busy time and then the pointer reverts back to my chosen pointer.

For applications I started after I switched the default mouse pointer I get the
same behavior as before -- one frame of the animated busy mouse pointer during
busy times, nothing more.

It seems like the reversion to the small animated pointer is some kind of
session error; almost as if something were caching all the necessary mouse
images during application launch and then showing me whatever the cache has
available for that application.  I don't actually know if this is in any way
accurate to what's really going on, I'm just trying to describe the behavior.
Comment 13 Andrew Benham 2007-08-28 05:44:35 EDT
Observed in FC7:
If one changes the pointer size, then one loses the animated busy pointer and
there's no way to get it back from the UI.  I.e. if one reverts to the default
size, the animation is still absent.

One has to hand-edit ~/.gconf/desktop/gnome/peripherals/mouse/%gconf.xml to
remove both the theme and the size.

I was hoping that removing just the theme would have given me a larger animated
pointer, but no luck.
Comment 14 Matěj Cepl 2007-08-28 08:19:40 EDT
While reading this bug again, I cannot understand why in the world I haven't
appointed it to the correct component a long time ago. Reporter, I am really
sorry, but now it should be in better hands.
Comment 15 Ray Strode [halfline] 2007-08-28 09:53:08 EDT
we just never got good cursor coverage for the big cursors. We only did the
first frame.  We don't have an artist right... We may want to ask
fedora-art-list for the additional frames.
Comment 16 E Mair 2007-11-28 19:23:31 EST
Fedora 8 has been out for a while now, with broken wait cursor. Sigh.
Did anyone ever ask on that fedora-art-list? Where did the original artist go,
the one who made the tiny default cursor?

Are there instructions anywhere online on how to make a mouse pointer theme
myself? (I.e. which file format, what to do with the files et c.)

BTW, why is "version" set to "devel"?
Comment 17 Bug Zapper 2008-04-03 13:10:06 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 18 E Mair 2008-04-03 15:44:35 EDT
(In reply to comment #17)

> (If you're unable to change the bug's version
> or status, add a comment to the bug and someone will change it for you.)

As stated earlier, the bug is present in Fedora 8.
Comment 19 Ray Strode [halfline] 2008-04-03 16:29:07 EDT
cursors got moved to bluecurve-icon-theme in f8, changing component.
Comment 20 Matthias Clasen 2008-04-23 01:51:51 EDT

*** This bug has been marked as a duplicate of 180616 ***

Note You need to log in before you can comment on or make changes to this bug.