Bug 1861025 - RedFish Virtual media install (idrac-virtualmedia) fails if a Virtual Media image is already connected
Summary: RedFish Virtual media install (idrac-virtualmedia) fails if a Virtual Media i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Derek Higgins
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-27 16:36 UTC by rlopez
Modified: 2020-10-27 16:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:17:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
Conductor log (18.31 MB, text/plain)
2020-07-27 16:36 UTC, rlopez
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:20:37 UTC

Description rlopez 2020-07-27 16:36:38 UTC
Created attachment 1702561 [details]
Conductor log

Description of problem:

Attempting an installation using idrac-virtualmedia on Dell systems and it errored with the following:

2020-07-27 16:10:30.740 1 ERROR ironic.drivers.modules.inspector [req-9a90de2f-bdd0-4755-8d56-5733b62979aa - - - - -] Unable to start managed inspection for node 6c25dd31-9b65-48f8-9dba-19d75321e4db: HTTP POST https://r640-c12u09-drac.cloud.lab.eng.bos.redhat.com/redfish/v1/Managers/iDRAC.Embedded.1/VirtualMedia/CD/Actions/VirtualMedia.InsertMedia returned code 500. Base.1.5.GeneralError: The Virtual Media image server is already connected.: sushy.exceptions.ServerSideError: HTTP POST https://r640-c12u09-drac.cloud.lab.eng.bos.redhat.com/redfish/v1/Managers/iDRAC.Embedded.1/VirtualMedia/CD/Actions/VirtualMedia.InsertMedia returned code 500. Base.1.5.GeneralError: The Virtual Media image server is already connected.


The reason for the error is because a virtual media image was already connected. Prior to ironic attempting to attach a virtual media image, it should attempt to disconnect any existing image. 


NOTE: I suspect this probably true for redfish-virtualmedia as well if using HPE systems. 

Version-Release number of selected component (if applicable): 4.6




Steps to Reproduce:
1. Have an existing Virtual Media attached
2. Attempt IPI on BM install using idrac-virtualmedia


Actual results: Fails with an error saying The Virtual Media image server is already connected.


Expected results: Would of attached the Virtual Media properly and installed.

Comment 1 rlopez 2020-07-27 17:12:24 UTC
FYI - I manually disconnected the Virtual Media, re-ran and got the same error.

Comment 2 Derek Higgins 2020-08-25 11:34:48 UTC
(In reply to rlopez from comment #1)
> FYI - I manually disconnected the Virtual Media, re-ran and got the same
> error.

Does this suggest that can't get idrac-virtualmedia to work at all or is it only a problem on a specific environment? If you have it reproduced can you send me the details to have a look?

Comment 3 rlopez 2020-08-25 17:10:06 UTC
Hey Derek,

Just posting here that we synced on slack and to further troubleshoot the issue on there.

Comment 4 Derek Higgins 2020-08-26 09:59:01 UTC
After trying various firmware versions on another host where this works and comparing the settings on a iDrac that works with this one

Configuration->Virtual Media->Attach Mode->AutoAttach your was set to "Detached", 

When changed to AutoAttach and it now works (using curl to simulate what ironic does)

it looks like this was the problem and we can close this once its confirmed with a full run.
If it was the problem, we should document the requirement, I'll take a look upstream to see where is suitable.

Comment 5 rlopez 2020-08-26 13:08:11 UTC
Hi Derek,

The systems I'm using Dell PowerEdge R640, already have Virtual Media set to AutoAttach.

Comment 6 rlopez 2020-08-26 20:48:05 UTC
Unfortunately due to https://bugzilla.redhat.com/show_bug.cgi?id=1872787, this is difficult to test as it requires the provisioning network to be routable (which we declare as a non-routable network) since the BMC of the servers is not on the provisioning network but instead an external network.

Comment 7 Derek Higgins 2020-09-14 11:17:50 UTC
From discussions outside of bugzilla I believe that ensuring that "Attach Mode" is set to AutoAttach fixes the problem,
@rlopez can you confirm if this is the case, if so we can update the docs to ensure its documented as a requirement.

Comment 8 rlopez 2020-09-29 13:11:13 UTC
Confirmed. With AutoAttach set, the installation works as expected. Requires 4.6.0-0.nightly-2020-09-28-061045 or higher to test.

Comment 12 errata-xmlrpc 2020-10-27 16:17:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196

Comment 13 errata-xmlrpc 2020-10-27 16:20:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.