Bug 1861219 - [sriov] sriovnetworknodestates cannot be restored if it was deleted
Summary: [sriov] sriovnetworknodestates cannot be restored if it was deleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: All
OS: All
high
medium
Target Milestone: ---
: 4.6.0
Assignee: Peng Liu
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks: 1861220
TreeView+ depends on / blocked
 
Reported: 2020-07-28 05:54 UTC by zhaozhanqi
Modified: 2020-10-27 16:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1861220 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:17:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift sriov-network-operator pull 313 0 None closed Watch the node state CR by controller 2020-10-27 15:25:56 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:21:03 UTC

Description zhaozhanqi 2020-07-28 05:54:48 UTC
Description of problem:

When deleted the sriovnetworknodestates CR, it cannot be restored by operator

Version-Release number of selected component (if applicable):
4.6

How reproducible:
always

Steps to Reproduce:
1. setup the sriov opreator
2. set the nodeselect to make the config daemon pod working on node
3. Check the sriovnetworknodestates
oc get sriovnetworknodestates.sriovnetwork.openshift.io
4. Delete the sriovnetworknodestates CR

5. Check the sriovnetworknodestates again.

Actual results:

step 5. 
sriovnetworknodestates CR was deleted and cannot be restored

Expected results:
sriovnetworknodestates CR should be restored 

Additional info:

Comment 3 zhaozhanqi 2020-07-30 06:00:47 UTC
Verified this bug on 4.6.0-202007291741.p0

Comment 5 errata-xmlrpc 2020-10-27 16:17:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196

Comment 6 errata-xmlrpc 2020-10-27 16:21:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.