Bug 1861427 - [4.6] [NMO] [UI] Can't Stop Maintenance from "Status" popover
Summary: [4.6] [NMO] [UI] Can't Stop Maintenance from "Status" popover
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.6.0
Assignee: Jiri Tomasek
QA Contact: mlammon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-28 15:25 UTC by mlammon
Modified: 2020-10-27 16:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:21:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
ImageFromOCPUI (48.55 KB, image/png)
2020-07-28 15:26 UTC, mlammon
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:21:40 UTC

Description mlammon 2020-07-28 15:25:26 UTC
Description of problem:
Can't Stop Maintenance from "Status" popover

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Install OCP 4.6
2. Install CNV 2.4 (needing Node Maintenance Operator (NMO))
3. From UI, Nodes-> worker-0-X , three dots -> Start Maintenance
< worker node successfully into node maintenance >
4. clock on worker-0-X , popup in status and try clicking "Stop Maintenance"
< it will not work> 

Actual results:
worker-0-X node will not stop maintenance from status popover

Expected results:
Stop maintenance and return to Ready status

Additional info:

oc get clusterversion
NAME      VERSION                        AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.ci-2020-07-21-114552   True        False         17h     Cluster version is 4.6.0-0.ci-2020-07-21-114552



WorkAround:
If you click the 3dots-> Stop Maintenance it will work and put node back to Ready
This is a regression case and worked it previous releases.

Comment 1 mlammon 2020-07-28 15:26:08 UTC
Created attachment 1702675 [details]
ImageFromOCPUI

Comment 2 Rastislav Wagner 2020-09-16 12:09:20 UTC
There was a PF bug which caused buttons in popovers to stop working. Openshift updated PF and the issue should be gone. I just tried and everything works fine. Can you try again ?

Comment 3 Yadan Pei 2020-09-18 07:08:56 UTC
Hi, could you please tell me how did you install CNV Operator? via OperatorHub or create yamls?

Comment 5 Yadan Pei 2020-09-29 02:56:34 UTC
1. Install OCP 4.6
2. Install CNV 2.3
3. Set a node to Maintenance mode by Nodes -> worker-0-x -> three dots ... -> Start Maintenance, wait for some minutes and the node will become 'Under Maintenance' status
4. From UI, Nodes-> worker-0-X, click 'Under Maintenance' in status and a popup is open -> try clicking "Stop Maintenance", the node exit maintenance mode successfully and is shown 'Provisioned'


Verified on 4.6.0-0.nightly-2020-09-27-075304

Comment 8 errata-xmlrpc 2020-10-27 16:21:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.