Bug 186143 - Crash when gnome-cd autostarts after connecting external CD drive
Crash when gnome-cd autostarts after connecting external CD drive
Status: CLOSED DUPLICATE of bug 183991
Product: Fedora
Classification: Fedora
Component: cdparanoia (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 15:55 EST by Kjartan Maraas
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-02 16:13:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2006-03-21 15:55:24 EST
Description of problem:

Attached my USB based CD-RW device with a CD in it.

Version-Release number of selected component (if applicable):


How reproducible:
Happens every time here.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Crash with the following backtrace:

(gdb) bt
#0  0x00e15402 in ?? ()
#1  0x00bd9a3b in ?? () from /lib/libpthread.so.0
#2  0x004b2086 in libgnomeui_segv_handle (signum=11) at gnome-ui-init.c:792
#3  <signal handler called>
#4  0x017f3b77 in sg2_setup_scsi_cmd (d=0x85f8398, cmdp=0xbfbdd572 "Z",
cmd_len=10, in_size=0, out_size=22)
    at scsi_interface.c:396
#5  0x017f4223 in mode_sense_atapi (d=0x85f8398, size=22, page=42) at
scsi_interface.c:578
#6  0x017f43f1 in mode_sense (d=0x85f8398, size=22, page=42) at scsi_interface.c:618
#7  0x017f7ac2 in check_mmc (d=0x85f8398) at scsi_interface.c:1510
#8  0x017f7ead in scsi_init_drive (d=0x85f8398) at scsi_interface.c:1573
#9  0x017f7d4a in scsi_inquiry (d=0x85f8398) at scsi_interface.c:1557
#10 0x017eeb01 in sgio_cdda_identify_scsi (generic_device=0x85dd000 "/dev/scd0",
ioctl_device=0x0, messagedest=0,
    messages=0x0) at scan_devices.c:538
#11 0x017eeda9 in cdda_identify_scsi (generic_device=0x85dd000 "/dev/scd0",
ioctl_device=0x0, messagedest=0,
    messages=0x0) at scan_devices.c:610
#12 0x017ed90b in cdda_identify (device=0x85dd000 "/dev/scd0", messagedest=0,
messages=0x0) at scan_devices.c:130
#13 0x0160d713 in gst_cd_paranoia_src_open (cddabasesrc=0x85de000,
device=0x85dd000 "/dev/scd0")
    at gstcdparanoiasrc.c:190
#14 0x016c281e in gst_cdda_base_src_start (basesrc=0x85de000) at
gstcddabasesrc.c:1374
#15 0x0063dfe9 in gst_base_src_start (basesrc=0x85de000) at gstbasesrc.c:1568
#16 0x0063f1cb in gst_base_src_activate_push (pad=0x85dc1a8, active=1) at
gstbasesrc.c:1698
#17 0x005d6ad3 in gst_pad_activate_push (pad=0x85dc1a8, active=1) at gstpad.c:798
#18 0x005d6c45 in gst_pad_activate_default (pad=0x85dc1a8) at gstpad.c:550
#19 0x005d7286 in gst_pad_set_active (pad=0x85dc1a8, active=1) at gstpad.c:638
#20 0x005c0d8e in activate_pads (pad=0x85dc1a8, ret=0xbfbddc98,
active=0xbfbddc88) at gstelement.c:2250
#21 0x005cb5f7 in gst_iterator_fold (it=0x85dce78, func=0x5c0d60
<activate_pads>, ret=0xbfbddc98, user_data=0xbfbddc88)
    at gstiterator.c:503
#22 0x005c07fb in iterator_fold_with_resync (iter=0x85dce78, func=0x5c0d60
<activate_pads>, ret=0xbfbddc98,
    user_data=0xbfbddc88) at gstelement.c:2268
#23 0x005c08d8 in gst_element_pads_activate (element=0x85de000, active=1) at
gstelement.c:2305
#24 0x005c0d4d in gst_element_change_state_func (element=0x85de000,
transition=GST_STATE_CHANGE_READY_TO_PAUSED)
    at gstelement.c:2354
#25 0x0063f46f in gst_base_src_change_state (element=0x85de000,
transition=GST_STATE_CHANGE_READY_TO_PAUSED)
    at gstbasesrc.c:1813
#26 0x005bd428 in gst_element_change_state (element=0x85de000,
transition=GST_STATE_CHANGE_READY_TO_PAUSED)
---Type <return> to continue, or q <return> to quit---
    at gstelement.c:2173
#27 0x005bd552 in gst_element_change_state (element=0x85de000,
transition=GST_STATE_CHANGE_NULL_TO_READY)
    at gstelement.c:2206
#28 0x005c0478 in gst_element_set_state_func (element=0x85de000,
state=GST_STATE_PAUSED) at gstelement.c:2135
#29 0x005bc5c3 in gst_element_set_state (element=0x85de000,
state=GST_STATE_PAUSED) at gstelement.c:2045
#30 0x005b1f82 in gst_bin_change_state_func (element=0x85d60e8,
transition=GST_STATE_CHANGE_READY_TO_PAUSED)
    at gstbin.c:1710
#31 0x005d94fa in gst_pipeline_change_state (element=0x85d60e8,
transition=GST_STATE_CHANGE_READY_TO_PAUSED)
    at gstpipeline.c:411
#32 0x00e5351b in gst_play_base_bin_change_state (element=0x85d60e8,
transition=GST_STATE_CHANGE_READY_TO_PAUSED)
    at gstplaybasebin.c:1789
#33 0x00e4e7e0 in gst_play_bin_change_state (element=0x85d60e8,
transition=GST_STATE_CHANGE_READY_TO_PAUSED)
    at gstplaybin.c:1321
#34 0x005bd428 in gst_element_change_state (element=0x85d60e8,
transition=GST_STATE_CHANGE_READY_TO_PAUSED)
    at gstelement.c:2173
#35 0x005bd552 in gst_element_change_state (element=0x85d60e8,
transition=GST_STATE_CHANGE_NULL_TO_READY)
    at gstelement.c:2206
#36 0x005c0478 in gst_element_set_state_func (element=0x85d60e8,
state=GST_STATE_PAUSED) at gstelement.c:2135
#37 0x005bc5c3 in gst_element_set_state (element=0x85d60e8,
state=GST_STATE_PAUSED) at gstelement.c:2045
#38 0x0805a1b7 in gst_cdrom_ensure_open (cdrom=0x8495400) at gst-cdrom.c:803
#39 0x0805abbd in gst_cdrom_update_cd (gnome_cdrom=0x8495400) at gst-cdrom.c:839
#40 0x08056e87 in gnome_cdrom_update_cd (cdrom=0x8495400) at cdrom.c:749
#41 0x08056f6a in gnome_cdrom_construct (cdrom=0x8495400, device=0x85d2a78
"/dev/scd0",
    update=GNOME_CDROM_UPDATE_CONTINOUS, lifetime=GNOME_CDROM_DEVICE_STATIC,
error=0xbfbde2a4) at cdrom.c:853
#42 0x0805ae2f in gnome_cdrom_new (cdrom_device=0x85d2a78 "/dev/scd0",
update=GNOME_CDROM_UPDATE_CONTINOUS,
    error=0xbfbde2a4) at gst-cdrom.c:716
#43 0x080521b8 in main (argc=Cannot access memory at address 0xa
) at gnome-cd.c:636


Expected results:


Additional info:
Comment 1 Kjartan Maraas 2006-05-02 16:13:36 EDT
Looks like I filed this one before :-)

*** This bug has been marked as a duplicate of 183991 ***

Note You need to log in before you can comment on or make changes to this bug.