Bug 1861473 - Console links doesn't get updated without a browser refresh
Summary: Console links doesn't get updated without a browser refresh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Robb Hamilton
QA Contact: Yanping Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-28 17:16 UTC by Abhishek K N
Modified: 2020-10-27 16:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:21:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6180 0 None closed Bug 1861473: Watch ConsoleLinks so they update in the UI without refreshing 2020-09-09 03:52:15 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:21:40 UTC

Description Abhishek K N 2020-07-28 17:16:33 UTC
Description of problem:
ConsoleLinks doesn't get updated without a browser refresh. 

Version-Release number of selected component (if applicable): 4.6


How reproducible: Always

Steps to Reproduce:
1. Install OpenShift Service Mesh operator (refer OCP docs)
2. Create Service Mesh control plane
3. Navigate to project details page of the namespace where Service Mesh control plane is installed

Actual results:
Launcher card is not displayed

Expected results:
Launcher card shall be displayed with Kiali link

Additional info:
On refreshing the browser, Launcher card is displayed with Kiali link. ConsoleLinks are not watched & hence it needs application reload to fetch updated CR.

Comment 2 Robb Hamilton 2020-07-29 14:39:21 UTC
Lowering the severity as this is working as intended and designed.  Will change the behavior to watch ConsoleLinks in the near future.

Comment 3 Robb Hamilton 2020-07-31 14:02:22 UTC
Will address in the next sprint.

Comment 4 Robb Hamilton 2020-08-21 12:42:41 UTC
PR is waiting on re-tagging after rebase.

Comment 7 Yanping Zhang 2020-09-09 04:11:39 UTC
Checked on ocp 4.6 cluster with payload 4.6.0-0.nightly-2020-09-08-123737.
Steps to verify:
1. Install OpenShift Service Mesh operator。
2. Create Service Mesh control plane instance.(Kiali operator and Jaeger operator need to be installed in advance)
3. Navigate to project details page of the namespace where Service Mesh control plane is installed, there is "Open on kiali" link shown in Launcher card. No need to refresh browser.
The bug is fixed.

Comment 9 errata-xmlrpc 2020-10-27 16:21:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.