Bug 1861559 - must-gather pod is scheduled on Windows node
Summary: must-gather pod is scheduled on Windows node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Sebastian Soto
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-29 00:18 UTC by Sebastian Soto
Modified: 2020-10-27 16:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:21:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 509 0 None closed Bug 1861559: Only schedule must-gather pod on Linux nodes 2020-12-11 09:07:08 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:21:40 UTC

Description Sebastian Soto 2020-07-29 00:18:31 UTC
Description of problem:
oc adm must-gather is creating a pod which is getting scheduled on Windows nodes

Version-Release number of selected component (if applicable):
4.6

How reproducible:
Always

Steps to Reproduce:
1. Add a Windows node to a cluster
2. Run oc adm must-gather
Actual results:
[sebsoto@localhost must-gather]$ oc adm must-gather --image=quay.io/ssoto/test:mg --dest-dir=/tmp/must-gather
[must-gather      ] OUT Using must-gather plugin-in image: quay.io/ssoto/test:mg
[must-gather      ] OUT namespace/openshift-must-gather-22bcp created
[must-gather      ] OUT clusterrolebinding.rbac.authorization.k8s.io/must-gather-n7qm8 created
[must-gather      ] OUT pod for plug-in image quay.io/ssoto/test:mg created
[must-gather-gwqpx] OUT gather did not start: unable to pull image: ErrImagePull: rpc error: code = Unknown desc = image operating system "linux" cannot be used on this platform
[must-gather      ] OUT clusterrolebinding.rbac.authorization.k8s.io/must-gather-n7qm8 deleted
[must-gather      ] OUT namespace/openshift-must-gather-22bcp deleted
error: gather did not start for pod must-gather-gwqpx: unable to pull image: ErrImagePull: rpc error: code = Unknown desc = image operating system "linux" cannot be used on this platform

Expected results:
The must-gather is only scheduled on linux nodes.

Additional info:

Comment 4 RamaKasturi 2020-08-04 07:00:50 UTC
Verified bug with the payload below and must-gather ran fine. Verified it on AWS with ocp cluster having one node as windows node.

[ramakasturinarra@dhcp35-60 ~]$ oc version -o yaml
clientVersion:
  buildDate: "2020-08-01T15:16:53Z"
  compiler: gc
  gitCommit: 9cc7d778f864ef8795a851fde47ed5a25bfb18c5
  gitTreeState: clean
  gitVersion: 4.6.0-202008011451.p0-9cc7d77
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64
openshiftVersion: 4.6.0-0.nightly-2020-08-03-025909
serverVersion:
  buildDate: "2020-08-01T09:17:34Z"
  compiler: gc
  gitCommit: 805d21671dc2d55685c5e68c22aa90801d6388b0
  gitTreeState: dirty
  gitVersion: v4.6.0-202008011154.p0-dirty
  goVersion: go1.14.4
  major: "4"
  minor: 6+
  platform: linux/amd64

[ramakasturinarra@dhcp35-60 ~]$ oc get node -l kubernetes.io/os=windows
NAME                                         STATUS   ROLES    AGE   VERSION
ip-10-0-144-252.us-east-2.compute.internal   Ready    worker   20h   v1.19.0-rc.2

stdout here: http://pastebin.test.redhat.com/890178

However i see a error as below when must-gather runs, will raise a separate bug for it. Based on the above results moving it to verified.

Comment 6 errata-xmlrpc 2020-10-27 16:21:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.