Bug 1861709 - For automation: Provide a unique id for the "Download Discovery ISO" button
Summary: For automation: Provide a unique id for the "Download Discovery ISO" button
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: assisted-installer
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Rastislav Wagner
QA Contact: Udi Kalifon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-29 11:08 UTC by Udi Kalifon
Modified: 2020-10-27 16:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:21:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:21:39 UTC

Description Udi Kalifon 2020-07-29 11:08:39 UTC
Description of problem:
To support the test automation, after the ISO image was generated and ready to be downloaded, please add a unique id to the button in the dialog. Currently it only has these attributes:

<button class="pf-c-button pf-m-primary" type="button" data-ouia-component-type="PF4/Button" data-ouia-safe="true">Download Discovery ISO</button>

There are 4 elements on the page that match the same attributes.


Version-Release number of selected component (if applicable):
Assisted Installer UI version
    refs/heads/master (quay.io/ocpmetal/ocp-metal-ui:6ea08686e6236151f6d9f91fc78c16e431e10f4c)
Assisted Installer
    quay.io/ocpmetal/assisted-installer:latest
Assisted Installer Controller
    quay.io/ocpmetal/assisted-installer-controller:latest
Assisted Installer Service
    quay.io/ocpmetal/bm-inventory:latest
Discovery Agent
    quay.io/ocpmetal/agent:latest
Ignition Manifests and Kubeconfig Generate
    quay.io/ocpmetal/ignition-manifests-and-kubeconfig-generate:latest
Image Builder
    quay.io/ocpmetal/installer-image-build:latest


How reproducible:
100%

Steps to Reproduce:
1. Create a cluster
2. Get the ISO
3. Inspect the "Download Discovery ISO" button after the image is ready


Actual results:
No unique id

Comment 1 Rastislav Wagner 2020-08-18 10:17:23 UTC
https://github.com/mareklibra/facet-lib/pull/153

Comment 4 errata-xmlrpc 2020-10-27 16:21:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.