Bug 1861814 (CVE-2020-14348) - CVE-2020-14348 AMQ: Denial of Service via unrecognized field injection
Summary: CVE-2020-14348 AMQ: Denial of Service via unrecognized field injection
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2020-14348
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1861608
TreeView+ depends on / blocked
 
Reported: 2020-07-29 16:00 UTC by Dave Baker
Modified: 2021-02-16 19:35 UTC (History)
13 users (show)

See Also:
Fixed In Version: amq-online-1.5.2 enmasse-0.32.1
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in AMQ Online before 1.5.2, where injecting an invalid field to a user's address space configuration of the user namespace puts AMQ Online in an inconsistent state. In this inconsistent state, the AMQ Online components do not operate properly. For example, the failure of provisioning and the failure of creating addresses may occur. However, this issue does not impact already existing messaging clients or brokers.
Clone Of:
Environment:
Last Closed: 2020-07-31 13:26:23 UTC


Attachments (Terms of Use)

Description Dave Baker 2020-07-29 16:00:34 UTC
Injecting an invalid field to a user’s AddressSpace configuration of the user namespace puts AMQ in an inconsistent state, where the AMQ components of all of the other users do not operate properly, such as the failure of provisioning and the failure of creating addresses.

Comment 1 Dave Baker 2020-07-29 16:00:38 UTC
Acknowledgments:

Name: Jeremy Choi (Red Hat Product Security)

Comment 12 RaTasha Tillery-Smith 2020-12-15 15:59:50 UTC
Mitigation:

The user can work around the issue by repairing the resource and removing the invalid (top-level) field.


Note You need to log in before you can comment on or make changes to this bug.