Bug 18619 - DHCP interfaces should have a NO-DNS option
Summary: DHCP interfaces should have a NO-DNS option
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-07 20:56 UTC by compwiz
Modified: 2014-03-17 02:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-10 19:20:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description compwiz 2000-10-07 20:56:11 UTC
Generally when ifup uses an interface which uses DHCP and which updates
DNS, /etc/resolv.conf gets updated. /sbin/pump has an option -d which makes
sure /etc/resolv.conf isn't updated every time. This should be an option in
ifcfg-* so I don't have to edit ifup manually.

Comment 1 Nalin Dahyabhai 2000-10-10 18:10:08 UTC
This can also be controlled by editing your /etc/pump.conf file, but it might be
a good idea to add that as an option in the init script (by overloading
PEERDNS?) since I'm not sure how you do this in dhcpcd's configuration files.

Comment 2 compwiz 2000-10-10 19:20:39 UTC
Well, -R is the dhcpcd equivalent to -d in pump. And /etc/pump.conf isn't
created by default, so it wouldn't really be obvious.. it would make a lot more
sense to put it in a variable in ifcfg.. Basically this is what my lines 94 & 95
look like in /etc/sysconfig/network-scripts/ifup:

PUMPARGS="-d -h ${DHCP_HOSTNAME}"
DHCPCDARGS="-R -h ${DHCP_HOSTNAME}"
(As opposed to without -d & -R)


Comment 3 Bill Nottingham 2000-12-12 08:06:07 UTC
Sounds like a plan. Added in initscripts-5.53-1; just add
PEERDNS=no
to /etc/sysconfig/network-scripts/ifcfg-eth*.


Note You need to log in before you can comment on or make changes to this bug.