Bug 186211 - Ethereal doesn't clean up
Ethereal doesn't clean up
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ethereal (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
http://bugs.ethereal.com/bugzilla/sho...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-22 04:44 EST by Nigel Horne
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 01:16:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2006-03-22 04:44:04 EST
Description of problem:

Ethereal leaves files in /tmp when it finishes.

Version-Release number of selected component (if applicable):

ethereal-0.10.14-1.FC4.1

How reproducible:

Everytime

Steps to Reproduce:
1. Start ethereal
2. Capture some stuff
3. Stop ethereal
  
Actual results:

ls -l /tmp | fgrep ether:
-rw-------  1 root   root    303908 Mar 21 21:48 etherXXXXKLpYRp


Expected results:

Should remove the file.


Additional info:
Comment 1 Radek Vokal 2006-03-27 03:53:36 EST
Works fine on my FC4 system. 

root@gigolo tmp# ls | grep ether
etherXXXXi9lHbX
root@gigolo tmp# ls | grep ether

Don't know what should be a problem on your machine. 
Comment 2 Nigel Horne 2006-03-27 04:57:49 EST
I have tried on a "clean" installation, updated with yum and it still fails.

Please retry using that scenario, since it fails on all of my machines running
FC4, whatever the configuration and other software.
Comment 3 Nigel Horne 2006-03-27 07:44:17 EST
[root@bandsman tmp]# ls -l ether*
ls: ether*: No such file or directory
[root@bandsman tmp]# rpm -q ethereal
ethereal-0.10.14-1.FC4.1
[root@bandsman tmp]# /usr/sbin/tethereal -R smtp
Capturing on eth0

[root@bandsman tmp]# ls -l ether*
-rw-------  1 root root 24 Mar 27 13:45 etherXXXXyl7jaU
[root@bandsman tmp]#
Comment 4 Radek Vokal 2006-03-27 07:58:54 EST
aha, so it happens only with tethereal, not with ethereal aka ethereal-gnome ..
Now I see the problem.
Comment 5 Radek Vokal 2006-04-03 01:16:31 EDT
Fixed upstream, will appear in next major release. 

Note You need to log in before you can comment on or make changes to this bug.