Bug 1862368 - openbabel-3.1.1 is available
Summary: openbabel-3.1.1 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openbabel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Antonio T. sagitter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1851021 (view as bug list)
Depends On: 1996330
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-31 09:09 UTC by Upstream Release Monitoring
Modified: 2021-11-13 11:42 UTC (History)
3 users (show)

Fixed In Version: openbabel-3.1.1-3.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-13 11:42:46 UTC
Type: ---


Attachments (Terms of Use)

Description Upstream Release Monitoring 2020-07-31 09:09:47 UTC
Latest upstream release: 112801
Current version/release in rawhide: 2.4.1-29.fc33
URL: https://github.com/openbabel/openbabel/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/2539/

Comment 1 Dominik 'Rathann' Mierzejewski 2020-08-19 13:12:51 UTC
The real latest upstream release is 3.1.1. There was an error in the regexp matching the versions on release-monitoring.org.

Comment 2 Dominik 'Rathann' Mierzejewski 2020-08-19 13:13:45 UTC
*** Bug 1851021 has been marked as a duplicate of this bug. ***

Comment 3 Susi Lehtola 2021-08-07 02:35:34 UTC
Hi Dominik,

is there any reason why OpenBabel hasn't been updated to the version 3 series? The current version in Fedora is 2.4.1 from 2016: it's five years old! It would really be nice to have an up-to-date version in Fedora, since a lot of software has changed and been developed within that time.

Comment 4 Dominik 'Rathann' Mierzejewski 2021-08-13 23:27:23 UTC
(In reply to Susi Lehtola from comment #3)
> is there any reason why OpenBabel hasn't been updated to the version 3
> series? The current version in Fedora is 2.4.1 from 2016: it's five years
> old! It would really be nice to have an up-to-date version in Fedora, since
> a lot of software has changed and been developed within that time.

Yes, I don't have time for openbabel anymore and I said so last year.
I'm going to wait till the end of the summer holidays and orphan it
unless someone wants to take it over.

Comment 5 Fedora Admin user for bugzilla script actions 2021-08-30 12:09:51 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 6 Antonio T. sagitter 2021-08-30 15:24:46 UTC
I'm working on the rpm packaging of new openbabel-3.1.1

Comment 7 Antonio T. sagitter 2021-08-31 12:56:02 UTC
openbabel-3.1.1 build on PPC64le is blocked by bug #1996330:

In file included from /usr/include/eigen3/Eigen/Core:350,
                 from /builddir/build/BUILD/openbabel-openbabel-3-1-1/include/openbabel/distgeom.h:34,
                 from /builddir/build/BUILD/openbabel-openbabel-3-1-1/src/distgeom.cpp:22:
/usr/include/eigen3/Eigen/src/Core/arch/AltiVec/MatrixProduct.h:1199:26: error: inlining failed in call to 'always_inline' 'Eigen::internal::bload<Eigen::internal::blas_data_mapper<double, long, 0, 0, 1>, double __vector(2), long, 2l, 0, 0>(Eigen::internal::PacketBlock<double __vector(2), 4>&, Eigen::internal::blas_data_mapper<double, long, 0, 0, 1> const&, long, long)void': target specific option mismatch
 1199 | EIGEN_ALWAYS_INLINE void bload(PacketBlock<Packet,4>& acc, const DataMapper& res, Index row, Index col)
      |                          ^~~~~
In file included from /usr/include/eigen3/Eigen/src/Core/arch/AltiVec/MatrixProduct.h:38,
                 from /usr/include/eigen3/Eigen/Core:350,
                 from /builddir/build/BUILD/openbabel-openbabel-3-1-1/include/openbabel/distgeom.h:34,
                 from /builddir/build/BUILD/openbabel-openbabel-3-1-1/src/distgeom.cpp:22:
/usr/include/eigen3/Eigen/src/Core/arch/AltiVec/MatrixProductMMA.h:39:57: note: called from here
   39 |   bload<DataMapper, Packet, Index, accCols, 0, ColMajor>(tRes, data, i, j);
      |   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~
gmake[2]: *** [src/CMakeFiles/openbabel.dir/build.make:835: src/CMakeFiles/openbabel.dir/distgeom.cpp.o] Error 1

Comment 8 Mamoru TASAKA 2021-08-31 13:02:37 UTC
If you want to build on ppc64le right now, you can workaround this by adding "-DEIGEN_ALTIVEC_DISABLE_MMA" to %optflags (ref: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/VKLO4JJ7VLZD5OOIE4IOFRA4RGH45PWT/ )

Comment 9 Antonio T. sagitter 2021-08-31 13:19:26 UTC
(In reply to Mamoru TASAKA from comment #8)
> If you want to build on ppc64le right now, you can workaround this by adding
> "-DEIGEN_ALTIVEC_DISABLE_MMA" to %optflags (ref:
> https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/
> message/VKLO4JJ7VLZD5OOIE4IOFRA4RGH45PWT/ )

Thank you

Comment 10 Mamoru TASAKA 2021-09-12 05:00:38 UTC
Now eigen3-3.4.0-3.fc36 has the above "DEIGEN_ALTIVEC_DISABLE_MMA" workaround and
openbabel side can remove it.

Comment 11 Fedora Update System 2021-11-13 11:42:46 UTC
FEDORA-2021-b60fd951a9 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.