Bug 186241 - Error when clicking on linked PDF in firefox
Summary: Error when clicking on linked PDF in firefox
Status: CLOSED DUPLICATE of bug 193582
Alias: None
Product: Fedora
Classification: Fedora
Component: evince   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 193582
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-22 14:48 UTC by Nils Philippsen
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 18:57:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nils Philippsen 2006-03-22 14:48:21 UTC
Description of problem:

When I click on a PDF file/link in firefox it tries to display it via
mozplugger/evince, but I get the error message "Unable to open document --
Unhandled MIME type: 'application/octet-stream'"

Version-Release number of selected component (if applicable):

evince-0.5.1-3
mozplugger-1.7.3-2.2.1
firefox-1.5.0.1-9

How reproducible:


Steps to Reproduce:
1. Click on linked PDF in firefox
  
Actual results:
Evince window gets drawn inside firefox, but I get the error message as
described above.

Expected results:
PDF gets displayed

Additional info:
When I subsequently issue "evince http://webserver/path/to/doc.pdf", the
document gets downloaded and displayed fine.

Comment 1 Eric Raymond 2006-05-05 13:48:42 UTC
This bug reproduces on my AMD-64 but not on my 32-bit laptop.


Comment 2 Nils Philippsen 2006-05-05 15:27:15 UTC
NB: I have this problem both on my 32-bit Intel Pentium M laptop and 32-bit AMD
Athlon desktop.

Comment 3 Alex Lancaster 2006-06-07 01:42:30 UTC
Confirming on my 32-bit Intel laptop.  This also affects all other browsers I've
tried: galeon and epiphany both give the same error.

Comment 4 Alex Lancaster 2006-06-08 07:37:43 UTC
I can duplicate this outside firefox/galeon/epiphany.  The underlying problem
appears to be that evince apparently isn't using file magic to check that it's
really a PDF. i.e. if the PDF doesn't have the .pdf extension when downloaded
via mozplugger it is seen as the default binary type:

$ cp doc.pdf /tmp/doc

$ evince /tmp/doc

get same problem as doing it via a browser.

Comment 5 Alex Lancaster 2006-06-08 07:51:35 UTC
See also discussion here:

http://www.redhat.com/archives/fedora-list/2006-April/msg02134.html



Comment 6 Alex Lancaster 2006-06-08 09:31:35 UTC
This looks to be a duplicate/special case of bug #193582.

Comment 7 Alex Lancaster 2006-06-29 15:55:56 UTC
Can this be closed as a duplicate of bug #193582?  shared-mime-info-0.17-1.fc5.2
has been pushed for fc5 which fixes this.

Comment 8 Kristian Høgsberg 2006-06-29 18:57:17 UTC
Done, thanks.

*** This bug has been marked as a duplicate of 193582 ***


Note You need to log in before you can comment on or make changes to this bug.