Bug 1862538 - MCDDrainError firing as critical instead of as warning
Summary: MCDDrainError firing as critical instead of as warning
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.z
Assignee: Kirsten Garrison
QA Contact: Yu Qi Zhang
URL:
Whiteboard:
Depends On: 1861876
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-31 16:22 UTC by Kirsten Garrison
Modified: 2020-09-08 10:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-08 10:54:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1966 0 None closed [release-4.5] Bug 1862538: telemetry: change MCDDrainErr from critical to warning 2020-10-13 16:17:21 UTC
Red Hat Product Errata RHBA-2020:3510 0 None None None 2020-09-08 10:54:35 UTC

Description Kirsten Garrison 2020-07-31 16:22:22 UTC
This bug was initially created as a copy of Bug #1861876

I am copying this bug because: 



MCDDrainError firing as critical on all drain failures, this is very misleading especially given PDBs. This should have been written as a warning.

Comment 4 Yu Qi Zhang 2020-08-21 15:12:47 UTC
Confirmed working with the steps in https://bugzilla.redhat.com/show_bug.cgi?id=1861876#c4

For release: 4.5.0-0.nightly-2020-08-20-235458

Comment 6 errata-xmlrpc 2020-09-08 10:54:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.8 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3510


Note You need to log in before you can comment on or make changes to this bug.