Bug 1862607 - [LSO] auto discovery should display disk size in a user friendly format. [NEEDINFO]
Summary: [LSO] auto discovery should display disk size in a user friendly format.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.6.0
Assignee: Santosh Pillai
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-31 19:47 UTC by Santosh Pillai
Modified: 2020-10-27 16:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:21:54 UTC
Target Upstream Version:
sabose: needinfo? (hekumar)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift local-storage-operator pull 135 0 None closed Bug 1862607: [Auto discovery]: change device size format to int64 2020-10-01 08:11:49 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:22:21 UTC

Description Santosh Pillai 2020-07-31 19:47:03 UTC
Description of problem:

Currently, LocalVolumeDiscovery result in LSO display disk size in integer bytes as resource.Quantity. We need to change the type from resource.Quanity to int64

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start LSO operator
2. Apply local volume discovery CR
3. Observe the disk size in the discovery result status. 

Actual results:
Currently the auto discovery in LSO display disk size in integer bytes as resource.Quantity

Expected results:
This should be updated from resource.Quanity to int64


Additional info:

Comment 1 Sahina Bose 2020-08-24 08:20:51 UTC
Hemant, can you review and merge PR? We have some UI work blocked on this.

Comment 4 Chao Yang 2020-09-02 08:38:58 UTC
Verify is passed with local-storage-operator.4.6.0-202008311758.p0
nvme2n1                      259:6    0     3G  0 disk 
`-nvme2n1p1                  259:9    0     2G  0 part 

oc get pv
NAME                CAPACITY   ACCESS MODES   RECLAIM POLICY   STATUS      CLAIM   STORAGECLASS   REASON   AGE
local-pv-7f35646    2Gi        RWO            Delete           Available           lvs-part                2s

Comment 5 Chao Yang 2020-09-02 11:27:49 UTC
  - deviceID: /dev/disk/by-id/nvme-Amazon_Elastic_Block_Store_vol0b71cc5533914c3b3-part1
    fstype: ext4
    model: ""
    path: /dev/nvme2n1p1
    property: NonRotational
    serial: ""
    size: 2147483648
    status:
      state: NotAvailable
    type: part
    vendor: ""

Comment 8 errata-xmlrpc 2020-10-27 16:21:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.