Bug 186279 - metacity crashes on enabling transparency
Summary: metacity crashes on enabling transparency
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-22 17:52 UTC by Andrea Santilli
Modified: 2014-06-18 09:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-08 02:48:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
metacity 2.14.0-1 backtrace (14.42 KB, text/plain)
2006-03-23 12:30 UTC, Andrea Santilli
no flags Details

Description Andrea Santilli 2006-03-22 17:52:47 UTC
Description of problem:
I tested both aiglx (a bit slow) and exa compositions with kwin and everything
is ok.
Then i wanted to test the new effects with metacity but as soon as I do:
gconftool-2 -s '/apps/metacity/general/compositing_manager' --type bool true
metacity crashes.
Starting metacity from xterm, when i enable the composition and the wm crashes
there can be read:

composite all adds window (this line is repeated a lot of times)
....
composite all ends
Avviso del window manager: Log level 6: Unexpected X error:
GLXUnsupportedPrivateRequest serial 1612 error_code 162 request_code 143
minor_code 16)
Please notice that this happens on both aiglx and exa.


Version-Release number of selected component (if applicable): 2.14.0-1


How reproducible:
Always


Steps to Reproduce:
1. Enable exa or aiglx and restart X
2. login in gnome and enable metacity's compositor by gconf2-editor
3. metacity crashes (you can also see metacity restarting and re-crashing for a
while)
  
Actual results:
metacity crashes on composition

Expected results:
to not crash

Additional info:
I don't know if this can help you. My videocard is a
Sapphire Radeon 9000 Atlantis [RV250]

Comment 1 Andrea Santilli 2006-03-23 11:26:41 UTC
i cant do the backtrace because gdb locks the screen until i kill it

Comment 2 Andrea Santilli 2006-03-23 12:30:25 UTC
Created attachment 126539 [details]
metacity 2.14.0-1 backtrace 

I've managed to get the backtrace from metacity.

Comment 3 Marius Andreiana 2006-03-26 14:35:39 UTC
I confirm the same behaviour (FC5, same metacity version). 

I've added this to xorg.conf:
Section "Extensions"
        Option "Composite"      "Enable"
EndSection

Comment 4 Andrea Santilli 2006-03-27 19:56:47 UTC
This bug seems to be metacity-only related: as i said before kwin works
perfectly; moreover i've rebuilt the xfwm rpm to include composite support and
it works good too.

Comment 5 Andrea Santilli 2006-03-30 12:45:38 UTC
I've managed to make Metacity work (still buggy) following the instructions
described at http://fedoraproject.org/wiki/RenderingProject/aiglx
I've installed the Xair server, changed the /usr/bin/X link from Xorg to Xair,
added the lines:
Option      "RenderAccel" "true"
Option	    "AccelMethod" "aiglx"
Option	    "XAANoOffscreenPixmaps"
in the Device section and enabled the Composite, RENDER and DAMAGE extensions.

After doing all this, metacity kept on crashing in runlevel 5 but worked when i
launched startx from command line (with wonderful but ugly and unconfigurable
effects)

So ive understood that the xserver included in FC5 isnt supposed to make aiglx
work but metacity crashes because there have been included some experimental
effect. Is it possible have plain metacity compositing effects? I mean such as
the ones included in kwin that just do shadows and transparent windows instead
of those ugly floating windows

Comment 6 Andrea Santilli 2006-04-09 16:10:02 UTC
Metacity crashes even on a GeForce FX5200. So it isn't a hardware related problem.

Comment 7 Filip Tsachev 2006-04-10 11:51:43 UTC
I can confirm with GB Radeon 9200, does it need "radeon" or "vesa" driver? I
think I tried both

Comment 8 Søren Sandmann Pedersen 2006-09-08 02:48:06 UTC
Closing compositor related bugs


Note You need to log in before you can comment on or make changes to this bug.